
Subject: Faked "Lightmap" Creation in 3D Studio Max - A Tutorial
Posted by Aircraftkiller on Mon, 19 Dec 2005 05:10:52 GMT
View Forum Message <> Reply to Message

Since Reborn refuses to show how simple their technique was, even though it was blatently
obvious (Texture baking in Max, press the zero key and you're almost at their skill level!), I've
decided to make this tutorial so that everyone can use lightmaps in their creations if you feel it's
worth the ridiculous amount of time necessary to do so.

You're going to need 3D Studio Max, any version that natively supports texture baking via the zero
key will suffice. You will also need the BFF Export plugin. You can find the BFF Export plugin at
FileFront's download service:

   http://www.filefront.com/?filepath=/renalert/BFFExporter.zip

Okay, now that you have the necessary files (ignore the MultiUnwrap plugin), now you need to
know how to install them! Drag and drop the BFF script into your Max viewport. Once you've done
that, select the Customize menu and select the Customize UI option. Click the Menu tab and
select the "Bobo_s Tools" category. Click the plus sign next to the File menu to open it, and drag
the "BFF_Exporter" item below the Export item. You're all done setting up your scripts,
congratulations!

This step can be slightly tricky, so if you need help please feel free to e-mail me at
aircraftkiller@cncgames.com if you have any questions.

Now to start helping you set up the faked lightmaps:

Load your Max file. For example, if you're making a building interior with lightmapping applied, be
sure to load said building interior so you can begin work with it. Make sure your scene's geometry
is complete. Set up all your lights the way you want them to look in-game, and make sure you've
got a Shadow Map applied for your lights, or Ray Traced Shadows. Either will produce great
results for the purpose we're using them for. Once all your lights are set up, select your main
piece of geometry (For reason's sake, the largest piece so it's easier to work with) and attach all
the scene's geometry to it. Before you do that, though, be absolutely sure to save your work
before doing the attachment so you don't have to worry about having a single instanced piece of
geometry if you wanted to have separate smaller pieces to work with. Add the Unwrap UVW
modifier and set it to UV channel 3.

Select the Mapping menu after you've brought up the UV vertex editing menu. Select the Flatten
Mapping option and leave the settings at default, press enter to allow Max to chug away for
however long it will take. On a 2.8 GHz machine, my Refinery interior (About 4,000 polygons)
takes about two seconds to finish. A slight delay is to be expected with any complicated scene, so
heads up if you have a slower system.

After you've run that, select the Tools menu and select the Pack UVs option. Change the packing
type to Recursive, change the spacing to 0.01, and check all the options beneath the spacing
spinner. Allow Max to restructure your UV coordinates to optimize map space (Since this is really
pointless to do yourself unless you're the masochistic type) and then convert everything to an
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editable poly object or an editable mesh object. Either one is irrelevant, just make sure not to
convert it to an editable patch object.

Once you've done that, keep the object selected and press zero on your keyboard's number strip.
When the Render to Texture (Texture bake menu) opens, make sure to tell Max the UV
coordinate your lightmaps are working off. Generally the number would be 2 or 3, depending on
which you used earlier. You tell Max how to bake the scene's radiosity into a texture by selecting
the Use Existing Channel option and setting it accordingly. On the output menu, click the Add
button and add the LightingMap option. Set the texture size at whatever you feel appropriate. 256
to 512 is more than enough for a building. 1024 is pushing it in any case.

Next to where your new lightmap's filename is, a button with three periods inside needs to be
clicked to set up your export path for the lightmap. Set it to some easy to find location, since the
default Max location is C:\YourMaxPath\Images.

Select the Render option and let Max chug away. Once you've done that, select File >
BFF_Exporter and uncheck everything but Geometry, Materials, and Progress Report. Export this
file to your workspace folder and close Max, or do whatever you want with it at that point. Load
RenX; the output will be a *.ms file. This MaxScript file can be read in gMax by using the
MaxScript > Run Script menu option. This saves your extra texture channel, allowing the
lightmaps to exist in the engine without having to remap everything in gMax to your lightmap's UV
coordinates (Again, unless you're the masochistic type, this really isn't recommended.).

Set up your textures in RenX as usual, but this time go to the Vertex Material tab. Set the detail
texture's UV channel to whatever your lightmap channel is. On the Shader tab, set the Detail
Color to Scale. On the Textures tab, set your Stage 1 (Detail Texture) to the lightmap's filename.
The Pass Hint should be set at Emissive Lightmap so the engine code knows exactly why it's
there, in case anyone decides to do a WDump analysis of your soon to be W3D file. Export to
W3D and check our your newly lightmapped building!

There's more work than this once you get it into LevelEdit, but I'll let you figure that out on your
own. I hope this helps everyone since Reborn seems to think that they're slick with an obvious
texture baking technique.

Subject: Re: Faked "Lightmap" Creation in 3D Studio Max - A Tutorial
Posted by Goztow on Mon, 19 Dec 2005 07:45:02 GMT
View Forum Message <> Reply to Message

It's not nice to be jealous, ACK... Even if it's not hard to do, it still needs to be done.

Subject: Re: Faked "Lightmap" Creation in 3D Studio Max - A Tutorial
Posted by Chronojam on Mon, 19 Dec 2005 07:57:30 GMT
View Forum Message <> Reply to Message

It *needs* to be done? Why hasn't anybody bothered or really cared publicly since just about 3
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years ago then?

And this is that attitude that's going to basically require us to do it now. Everybody now thinks it
"Needs" to be done, so we're going to need to go ahead and do it now. Renardin says we're
stupid and lazy if we don't now too; we'll ignore that a few seconds later he said it's sad that we
had to "copy", ya know? What the hell do people want: us to do it, or us to not do it? There's no
jealousy here, just serving the fans.

Subject: Re: Faked "Lightmap" Creation in 3D Studio Max - A Tutorial
Posted by Goztow on Mon, 19 Dec 2005 12:38:25 GMT
View Forum Message <> Reply to Message

Ah come on, read between the lines, man... 

I don't say YOU need to do it, i say even if it isn't all that difficult, they still are doing it and therefor
can get credit for it.

Subject: Re: Faked "Lightmap" Creation in 3D Studio Max - A Tutorial
Posted by Deleted_ on Mon, 19 Dec 2005 12:55:53 GMT
View Forum Message <> Reply to Message

Whether or not it's a pretty obvious and/or simple technique (that takes a while nevertheless), the
point is it makes Reborn's stuff look good. 

Besides Aircraftkiller, wasn't it you who went and traded something like 4 (around that range)
unreleased Renegade models or something, in exchange for a modified Dazzle.ini, which involved
copying and pasting a bit of code here and there, in order to make some goofy looking blood
spatters and vehicle lights show up in Renegade?

For simply moving some code around in a small ini file, making lights work and stuff is pretty good
anyways though. Shows how some small simple stuff can still make for some pretty bloody cool
results.

Subject: Re: Faked "Lightmap" Creation in 3D Studio Max - A Tutorial
Posted by Fabian on Mon, 19 Dec 2005 14:06:27 GMT
View Forum Message <> Reply to Message

If it were really that simple and obvious, the process wouldn't take you that long to describe.

Subject: Re: Faked "Lightmap" Creation in 3D Studio Max - A Tutorial
Posted by Titan1x77 on Mon, 19 Dec 2005 14:51:42 GMT
View Forum Message <> Reply to Message

Page 3 of 6 ---- Generated from Command and Conquer: Renegade Official Forums

http://renegadeforums.com/index.php?t=usrinfo&id=4882
http://renegadeforums.com/index.php?t=rview&th=18135&goto=182674#msg_182674
http://renegadeforums.com/index.php?t=post&reply_to=182674
http://renegadeforums.com/index.php?t=usrinfo&id=4189
http://renegadeforums.com/index.php?t=rview&th=18135&goto=182675#msg_182675
http://renegadeforums.com/index.php?t=post&reply_to=182675
http://renegadeforums.com/index.php?t=usrinfo&id=563
http://renegadeforums.com/index.php?t=rview&th=18135&goto=182682#msg_182682
http://renegadeforums.com/index.php?t=post&reply_to=182682
http://renegadeforums.com/index.php?t=usrinfo&id=133
http://renegadeforums.com/index.php?t=rview&th=18135&goto=182686#msg_182686
http://renegadeforums.com/index.php?t=post&reply_to=182686
http://renegadeforums.com/index.php


First of all there isn't much left to do in LE. Secondly there is quite a few steps you mentioned that
isn't necessary.

Seeing you never helped me out I'll let you figure it out on your own.

Reborn will be releasing a proper tutorial shortly after the release of the mod.

Subject: Re: Faked "Lightmap" Creation in 3D Studio Max - A Tutorial
Posted by sloth4urluv on Mon, 19 Dec 2005 15:09:50 GMT
View Forum Message <> Reply to Message

ACK I suggest you spend your time more wisely and work on your own mod instead of wasting
your time trying to bash our mod. When are you gonna realize that this is not a competition.
Besides leeching information from one of our exmembers im sure you knew I used texture baking
which isnt a big secret   
The process involves more than youve dumbed it down to. Of course you could merge all your
objects together into a single mesh and then unwrap, but then you have to break that merged
mesh back into its original pieces and if you used a good amount of textures on your model that
becomes a pain in the ass.

And what if you already have your building fully textured and rigged in gmax? Are you giong to
export to max, merge, unwrap, bake texture, break into original pieces, export to gmax, and fully
retexture again?

Subject: Re: Faked "Lightmap" Creation in 3D Studio Max - A Tutorial
Posted by Aircraftkiller on Mon, 19 Dec 2005 15:44:48 GMT
View Forum Message <> Reply to Message

Oh, but you made it out to be a "big secret" since you and Retardin claimed it wasn't texture
baking. I've never really seen a bunch of pathological liars like members of the Reborn team. You
claimed it was a secret technique that didn't involve texture baking, now once you're exp0sed; you
claim that it was what I said it was all along.

No, you don't have to break anything up. If you idiots knew much of anything about the W3D
engine this would be obvious. A building interior can be comprised of a single object and it's
completely able to run well in the game, with or without visibility rendering.

Quote:And what if you already have your building fully textured and rigged in gmax? Are you
giong to export to max, merge, unwrap, bake texture, break into original pieces, export to gmax,
and fully retexture again?

Not really, since Silent Kane's Max to W3D exporter circumvents that. 
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Subject: Re: Faked "Lightmap" Creation in 3D Studio Max - A Tutorial
Posted by sloth4urluv on Mon, 19 Dec 2005 16:03:30 GMT
View Forum Message <> Reply to Message

Never once said it wasnt texture baking, might have said it wasnt just texture baking.

And if you have such great love for the community and dont keep stuff from the community like
reborn then you should have no problem sharing silent kanes max plugin with everyone.  

Subject: Re: Faked "Lightmap" Creation in 3D Studio Max - A Tutorial
Posted by Aircraftkiller on Mon, 19 Dec 2005 16:06:00 GMT
View Forum Message <> Reply to Message

I'd rather not; Reborn members really don't have the faculties to use it.

Subject: Re: Faked "Lightmap" Creation in 3D Studio Max - A Tutorial
Posted by Sir Kane on Mon, 19 Dec 2005 16:51:01 GMT
View Forum Message <> Reply to Message

Sidenote: I was too lazy to make it hide/show pass options based on the current passcount.

Subject: Re: Faked "Lightmap" Creation in 3D Studio Max - A Tutorial
Posted by sloth4urluv on Mon, 19 Dec 2005 17:42:22 GMT
View Forum Message <> Reply to Message

Thats cool, never doubted that you didnt have it, just that you would never give it out   

Subject: Re: Faked "Lightmap" Creation in 3D Studio Max - A Tutorial
Posted by Renx on Mon, 19 Dec 2005 20:29:36 GMT
View Forum Message <> Reply to Message

sloth4urluv wrote on Mon, 19 December 2005 12:03And if you have such great love for the
community and dont keep stuff from the community like reborn then you should have no problem
sharing silent kanes max plugin with everyone.  

I believe that's up to SK, not Ack...
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Subject: Re: Faked "Lightmap" Creation in 3D Studio Max - A Tutorial
Posted by SuperFlyingEngi on Mon, 19 Dec 2005 23:04:47 GMT
View Forum Message <> Reply to Message

So ACK, if this is such an obvious technique why didn't you use it for RenAlert?

Subject: Re: Faked "Lightmap" Creation in 3D Studio Max - A Tutorial
Posted by rm5248 on Tue, 20 Dec 2005 00:08:05 GMT
View Forum Message <> Reply to Message

omg ack dats liek such a gud tutorial i will uz it 4 reborn

Subject: Re: Faked "Lightmap" Creation in 3D Studio Max - A Tutorial
Posted by YSLMuffins on Tue, 20 Dec 2005 01:59:48 GMT
View Forum Message <> Reply to Message

This is a great tutorial, but I do not wish to see the inevitable arguing that may ensue. I'll bump this
in a few days, maybe.
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