Renegade Public Forums
C&C: Renegade --> Dying since 2003™, resurrected in 2024!
Home » Tiberian Technologies / Blackhand Studios » Tiberian Technologies Forum » Weird walking glitch
Weird walking glitch [message #492578] Wed, 11 October 2017 05:42 Go to next message
Neijwiert is currently offline  Neijwiert
Messages: 124
Registered: October 2009
Karma: 0
Recruit
Ever since I came back after some time to play Renegade again I have the problem shown in the video below:

https://youtu.be/3oZ1YMKdr1M

I have this in every server. In the video it's in my own server as a demonstration. I don't think I had this problem pre 4.4
Re: Weird walking glitch [message #492579 is a reply to message #492578] Wed, 11 October 2017 09:55 Go to previous messageGo to next message
dblaney1 is currently offline  dblaney1
Messages: 358
Registered: March 2014
Location: United States
Karma: 0
Commander
Do you have vsync on? If you go over a certain fps i believe this glitch occurs. It might be that you upgraded your computer and it consistantly puts out more frames than your old one.

I don't have this issue on my end but I run vsync. I imagine my gtx1070 and i7 6820hk without vsync would easily get the fps for it though with it off though. Next time I am home I will try it out.

I strongly recommend turning on vsync. There is a lot of physics things in the w3d engine that rely on having a consistent frame time which vsync provides. Running it should greatly reduce the amount of lag you see since the behavior of objects will be more consistent with what the server is doing.

[Updated on: Wed, 11 October 2017 10:01]

Report message to a moderator

Re: Weird walking glitch [message #492580 is a reply to message #492579] Wed, 11 October 2017 13:09 Go to previous messageGo to next message
Neijwiert is currently offline  Neijwiert
Messages: 124
Registered: October 2009
Karma: 0
Recruit
dblaney1 wrote on Wed, 11 October 2017 09:55

Do you have vsync on? If you go over a certain fps i believe this glitch occurs. It might be that you upgraded your computer and it consistantly puts out more frames than your old one.

I don't have this issue on my end but I run vsync. I imagine my gtx1070 and i7 6820hk without vsync would easily get the fps for it though with it off though. Next time I am home I will try it out.

I strongly recommend turning on vsync. There is a lot of physics things in the w3d engine that rely on having a consistent frame time which vsync provides. Running it should greatly reduce the amount of lag you see since the behavior of objects will be more consistent with what the server is doing.


You are right, that was the problem. I forgot Renegade had those weird issues caused by framerate.
Re: Weird walking glitch [message #492590 is a reply to message #492580] Fri, 13 October 2017 10:04 Go to previous messageGo to next message
Jerad2142 is currently offline  Jerad2142
Messages: 3806
Registered: July 2006
Location: USA
Karma: 6
General (3 Stars)
Really wish we had made it just defaulted on, helps sync the physics engine with the server as well. Shame that emitters only seem to truly work correctly at 30fps instead of 60fps :\

Re: Weird walking glitch [message #492592 is a reply to message #492578] Fri, 13 October 2017 10:21 Go to previous messageGo to next message
dblaney1 is currently offline  dblaney1
Messages: 358
Registered: March 2014
Location: United States
Karma: 0
Commander
Whats wrong with emitters at 60fps?
Re: Weird walking glitch [message #492601 is a reply to message #492578] Fri, 13 October 2017 16:58 Go to previous messageGo to next message
Gen_Blacky is currently offline  Gen_Blacky
Messages: 3250
Registered: September 2006
Karma: 1
General (3 Stars)
Sometimes it will skip emitter frames at 60fps and most defiantly if you go over 1000fps. You notice a big difference if you watch a smoke emitter with vsync off and vsync on without being over 1000fps. Lets say 100fps with vsync off.

http://s18.postimage.org/jc6qbn4k9/bricks3.png
Re: Weird walking glitch [message #492616 is a reply to message #492592] Wed, 25 October 2017 17:10 Go to previous messageGo to next message
Jerad2142 is currently offline  Jerad2142
Messages: 3806
Registered: July 2006
Location: USA
Karma: 6
General (3 Stars)
dblaney1 wrote on Fri, 13 October 2017 11:21

Whats wrong with emitters at 60fps?

The Inheritance setting doesn't work consistently, I think it fails about 50% of the time at 60FPS if I recall correctly.


Re: Weird walking glitch [message #492618 is a reply to message #492616] Wed, 25 October 2017 20:52 Go to previous messageGo to next message
dblaney1 is currently offline  dblaney1
Messages: 358
Registered: March 2014
Location: United States
Karma: 0
Commander
Jerad Gray wrote on Wed, 25 October 2017 17:10

dblaney1 wrote on Fri, 13 October 2017 11:21

Whats wrong with emitters at 60fps?

The Inheritance setting doesn't work consistently, I think it fails about 50% of the time at 60FPS if I recall correctly.



Sounds like the code is broken in the same way the code for soldier ai rotation was. Its not taking frametime into account. I'll take a look at it since I was able to fix that code.

[Updated on: Wed, 25 October 2017 20:52]

Report message to a moderator

Re: Weird walking glitch [message #492631 is a reply to message #492578] Thu, 02 November 2017 10:25 Go to previous message
iRANian is currently offline  iRANian
Messages: 4300
Registered: April 2011
Karma: 0
General (4 Stars)
vsync causes input lag and is basically unplayable

Long time and well respected Renegade community member, programmer, modder and tester.

Scripts 4.0 private beta tester since May 2011.

My Renegade server plugins releases
Previous Topic: Scripts 4.5 is now available
Next Topic: EncyclopediaMgrClass
Goto Forum:
  


Current Time: Sat Jul 13 19:40:49 MST 2024

Total time taken to generate the page: 0.00851 seconds