Renegade Public Forums
C&C: Renegade --> Dying since 2003™, resurrected in 2024!
Home » Tiberian Technologies / Blackhand Studios » Tiberian Technologies Forum » 4.1 not loading my .ldd files?
4.1 not loading my .ldd files? [message #489785] Wed, 12 November 2014 18:24 Go to next message
Xpert is currently offline  Xpert
Messages: 1588
Registered: December 2005
Location: New York City
Karma: 0
General (1 Star)
So I recently updated all my projects to 4.1 and came across a problem with the server no reading my level modifications for my sniper server.

The .ldd files get read for the default maps like Volcano, Islands and the mission maps. But when I do a new map like Winter_Field or Uphill, none of my modifications get recognized like my edited spawns and path blockers.

I even redid all the maps in my repository and used the 4.1 PackageEditor to download them and I still had the same problem.


Is there something I'm missing?


http://i32.photobucket.com/albums/d42/XpertMaverick/xpertyankee.jpg

Creator of NetGuard, an IRC network regulator.
Developer of the CloudyServ 0.982-X project.
Developer of the CloudyServ Ren-X bot.

Part time streamer - https://twitch.tv/gg_wonder
Re: 4.1 not loading my .ldd files? [message #489786 is a reply to message #489785] Wed, 12 November 2014 18:53 Go to previous messageGo to next message
Gen_Blacky is currently offline  Gen_Blacky
Messages: 3250
Registered: September 2006
Karma: 1
General (3 Stars)
Well if your modified maps are using temps they are saved in the level .ddb file instead of the temps20 file and then being saved in the level .ddb file.

What happens when you try to open them?
The modifications just gone?
Leveledit should say your missing the presets if they are new presets and they are missing.
You should be using temp presets.
Le could just be removing them instead of trying to load them.

If they are not new/edited presets you shouldn't be having this problem.

Go back to the previous mod tools you where using resave them then try the 4.1 tools.

Edit:
Your going to want the .lvl files for the modifications and resave them.
Read your post thinking you where trying to use them in leveledit and not the server.


http://s18.postimage.org/jc6qbn4k9/bricks3.png

[Updated on: Wed, 12 November 2014 19:04]

Report message to a moderator

Re: 4.1 not loading my .ldd files? [message #489787 is a reply to message #489785] Wed, 12 November 2014 18:58 Go to previous messageGo to next message
Gen_Blacky is currently offline  Gen_Blacky
Messages: 3250
Registered: September 2006
Karma: 1
General (3 Stars)
http://www.renegadeforums.com/index.php?t=msg&goto=486416

http://s18.postimage.org/jc6qbn4k9/bricks3.png
Re: 4.1 not loading my .ldd files? [message #489793 is a reply to message #489786] Wed, 12 November 2014 22:50 Go to previous messageGo to next message
Xpert is currently offline  Xpert
Messages: 1588
Registered: December 2005
Location: New York City
Karma: 0
General (1 Star)
Gen_Blacky wrote on Wed, 12 November 2014 20:53


Edit:
Your going to want the .lvl files for the modifications and resave them.
Read your post thinking you where trying to use them in leveledit and not the server.


Ya this isn't level edit related lol. It's server related. They're .ldd files that aren't being recognized on any map other than the default and mission maps.

So what do you mean resave them? Do I just load up the lvl files and then just save it again? I don't get what that would do.


http://i32.photobucket.com/albums/d42/XpertMaverick/xpertyankee.jpg

Creator of NetGuard, an IRC network regulator.
Developer of the CloudyServ 0.982-X project.
Developer of the CloudyServ Ren-X bot.

Part time streamer - https://twitch.tv/gg_wonder
Re: 4.1 not loading my .ldd files? [message #489794 is a reply to message #489785] Wed, 12 November 2014 23:07 Go to previous messageGo to next message
Gen_Blacky is currently offline  Gen_Blacky
Messages: 3250
Registered: September 2006
Karma: 1
General (3 Stars)
"what do you mean resave them? Do I just load up the lvl files and then just save it again?"

yea


http://s18.postimage.org/jc6qbn4k9/bricks3.png
Re: 4.1 not loading my .ldd files? [message #489795 is a reply to message #489785] Thu, 13 November 2014 01:07 Go to previous messageGo to next message
Xpert is currently offline  Xpert
Messages: 1588
Registered: December 2005
Location: New York City
Karma: 0
General (1 Star)
I tried it with 2 maps. Didn't do anything. Result is still the same.

http://i32.photobucket.com/albums/d42/XpertMaverick/xpertyankee.jpg

Creator of NetGuard, an IRC network regulator.
Developer of the CloudyServ 0.982-X project.
Developer of the CloudyServ Ren-X bot.

Part time streamer - https://twitch.tv/gg_wonder
Re: 4.1 not loading my .ldd files? [message #489804 is a reply to message #489785] Thu, 13 November 2014 22:06 Go to previous messageGo to next message
Xpert is currently offline  Xpert
Messages: 1588
Registered: December 2005
Location: New York City
Karma: 0
General (1 Star)
Guess no one knows lol Sad

http://i32.photobucket.com/albums/d42/XpertMaverick/xpertyankee.jpg

Creator of NetGuard, an IRC network regulator.
Developer of the CloudyServ 0.982-X project.
Developer of the CloudyServ Ren-X bot.

Part time streamer - https://twitch.tv/gg_wonder
Re: 4.1 not loading my .ldd files? [message #489805 is a reply to message #489785] Fri, 14 November 2014 00:24 Go to previous messageGo to next message
EvilWhiteDragon is currently offline  EvilWhiteDragon
Messages: 3751
Registered: October 2005
Location: The Netherlands
Karma: 0
General (3 Stars)

Since you're specifically asking whether it's broken in 4.1, have you tried in some other version of renegade as well?

http://www.blackintel.org/usr/evilwhitedragon/pointfix.gif
BlackIntel admin/founder/PR dude (not a coder)
Please visit http://www.blackintel.org/

V, V for Vendetta

People should not be afraid of their governments.
Governments should be afraid of their people.
Re: 4.1 not loading my .ldd files? [message #489806 is a reply to message #489785] Fri, 14 November 2014 00:33 Go to previous messageGo to next message
Xpert is currently offline  Xpert
Messages: 1588
Registered: December 2005
Location: New York City
Karma: 0
General (1 Star)
I was running a 4.0 server for awhile. Same setup. All I did was update to 4.1 server files. My .ldd files work fine for default maps and mission maps. When I do new maps, the modifications don't apply to the maps. Basically, any map that isn't present in the data folder of the server doesn't load the modifications.

http://i32.photobucket.com/albums/d42/XpertMaverick/xpertyankee.jpg

Creator of NetGuard, an IRC network regulator.
Developer of the CloudyServ 0.982-X project.
Developer of the CloudyServ Ren-X bot.

Part time streamer - https://twitch.tv/gg_wonder
Re: 4.1 not loading my .ldd files? [message #489807 is a reply to message #489785] Fri, 14 November 2014 04:52 Go to previous messageGo to next message
EvilWhiteDragon is currently offline  EvilWhiteDragon
Messages: 3751
Registered: October 2005
Location: The Netherlands
Karma: 0
General (3 Stars)

AFAIK 4.1 does require you to specify the files that need to load in the config, if it's more then just the map. Maybe you could look into that.

http://www.blackintel.org/usr/evilwhitedragon/pointfix.gif
BlackIntel admin/founder/PR dude (not a coder)
Please visit http://www.blackintel.org/

V, V for Vendetta

People should not be afraid of their governments.
Governments should be afraid of their people.
Re: 4.1 not loading my .ldd files? [message #489813 is a reply to message #489785] Fri, 14 November 2014 14:21 Go to previous messageGo to next message
Xpert is currently offline  Xpert
Messages: 1588
Registered: December 2005
Location: New York City
Karma: 0
General (1 Star)
I don't think you understand it at all, no offense.

The maps work for default and mission maps. When I do new maps, the .ldd files don't work and my map edits don't appear.

If the map is in the data folder of the server, the map edit works but you're not suppose to have the map in the data folder unless this has changed in 4.1.

Here's an example of the tt.cfg

Canyon:
{
mapName = "C&C_Canyon";
packages = ["TTP_Sounds"];
serverPresetsFile = "objects.gm";
};
Carnage-Club:
{
mapName = "C&C_Carnage-Club_Xtreme";
packages = ["C&C_Carnage-Club_Xtreme", "TTP_Sounds"];
serverPresetsFile = "objects.gm";
};


As I said before, nothing was changed other than the update to 4.1. I know for a fact the maps aren't broken. All I did was upgrade to 4.1 from 4.0.


http://i32.photobucket.com/albums/d42/XpertMaverick/xpertyankee.jpg

Creator of NetGuard, an IRC network regulator.
Developer of the CloudyServ 0.982-X project.
Developer of the CloudyServ Ren-X bot.

Part time streamer - https://twitch.tv/gg_wonder
Re: 4.1 not loading my .ldd files? [message #489834 is a reply to message #489785] Sat, 15 November 2014 23:44 Go to previous message
Gen_Blacky is currently offline  Gen_Blacky
Messages: 3250
Registered: September 2006
Karma: 1
General (3 Stars)
make an actual .mix map and try it.

http://s18.postimage.org/jc6qbn4k9/bricks3.png
Previous Topic: Cannot connect to servers with the latest 4.1 patch (temporary fix)
Next Topic: Now collecting scripts 4.1 bugs
Goto Forum:
  


Current Time: Sun Jul 14 15:55:08 MST 2024

Total time taken to generate the page: 0.00648 seconds