Renegade Public Forums
C&C: Renegade --> Dying since 2003™, resurrected in 2024!
Home » Renegade Discussions » Mod Forum » Refinery/Harvester Issue
Refinery/Harvester Issue [message #489122] Thu, 28 August 2014 06:47 Go to next message
trunkskgb is currently offline  trunkskgb
Messages: 214
Registered: September 2003
Karma: 0
Recruit
I'm making a map and I'm almost done, but I have a problem with my GDI Harvester and it's way path.

I have a "temped" Refinery because I wanted a higher credit trickle amount.

Anyway,all my buildings are set, controllers, way paths, and path find generators and blockers. When the Harvester is made at the War Factory, it follows the path to the Tiberium Field.
It then returns to base, and unloads.
Then it does nothing. Nothing.
After it unloads, it just sits inside the Refinery bay, and stops moving and making any sounds at all.
Sometimes it makes two trips to the Tiberium field. Even when it makes that second trip, it never goes back out again.

I try bumping into it, pushing it, nothing.

I know the way paths are correct, because it follows them.

Why does it stop EVERYTHING after it unloads?

I've redone the way paths multiple times, I've redone the controllers, the path finding, I've even went back into max and re-added the building itself.

Could this be something in 4.1?

I literally don't know what else to do at this point.


My Renegade Maps
C&C Backstab || Rigdeline_b8 || C&C Halloween 2014 || Iron City (LE design) || Christmas Map (drafting)
Re: Refinery/Harvester Issue [message #489123 is a reply to message #489122] Thu, 28 August 2014 09:43 Go to previous messageGo to next message
Xpert is currently offline  Xpert
Messages: 1588
Registered: December 2005
Location: New York City
Karma: 0
General (1 Star)
I'm not a modding pro at making maps but probably something to do with you temping the GDI Refinery.

http://i32.photobucket.com/albums/d42/XpertMaverick/xpertyankee.jpg

Creator of NetGuard, an IRC network regulator.
Developer of the CloudyServ 0.982-X project.
Developer of the CloudyServ Ren-X bot.

Part time streamer - https://twitch.tv/gg_wonder
Re: Refinery/Harvester Issue [message #489143 is a reply to message #489122] Mon, 01 September 2014 15:00 Go to previous message
Gen_Blacky is currently offline  Gen_Blacky
Messages: 3250
Registered: September 2006
Karma: 1
General (3 Stars)
Delete your pathfind generators and readd them. That's how I always fixed weird issues with harvesters.
I noticed weird problems with path finding with 4.0/4.1 also. Redoing the generators usually solves the problem.


http://s18.postimage.org/jc6qbn4k9/bricks3.png

[Updated on: Mon, 01 September 2014 15:01]

Report message to a moderator

Previous Topic: Brenbot Question
Next Topic: First person view gun animation
Goto Forum:
  


Current Time: Sat Apr 13 08:34:05 MST 2024

Total time taken to generate the page: 0.00583 seconds