Renegade Public Forums
C&C: Renegade --> Dying since 2003™, resurrected in 2024!
Home » Renegade Discussions » Mod Forum » lod on emitters
lod on emitters [message #489081] Tue, 19 August 2014 13:02 Go to next message
roszek is currently offline  roszek
Messages: 296
Registered: June 2010
Karma: 0
Recruit
Does anyone know how to disable it? I looked through the w3d viewer and do not see anything to stop it, and it is really quite annoying to see it happen.

If I set the particles to 4 it goes to what it should look like when it happens but 4 is too much for the effect I want.

Re: lod on emitters [message #489083 is a reply to message #489081] Tue, 19 August 2014 16:17 Go to previous messageGo to next message
Jerad2142 is currently offline  Jerad2142
Messages: 3805
Registered: July 2006
Location: USA
Karma: 6
General (3 Stars)
This is actually controlled by the particle cap, knock that cap way up (via regedit) and you won't see it happen.

Re: lod on emitters [message #489086 is a reply to message #489083] Tue, 19 August 2014 21:11 Go to previous messageGo to next message
roszek is currently offline  roszek
Messages: 296
Registered: June 2010
Karma: 0
Recruit
Well there is a max particle cap under emissions in the w3d viewer but if I set it to anything other than 0 it breaks the emitter and crashes the viewer(well just about everything crashes the viewer), but you said via regedit...
...my 5 second search through mine revealed nothing todo with particles. Also will this adjustment just effect the way I view emitters cuz I'm trying to keep it from happening in the ones I'm creating. Perhaps you could be a bit more specific.
Re: lod on emitters [message #489088 is a reply to message #489086] Wed, 20 August 2014 05:49 Go to previous messageGo to next message
Jerad2142 is currently offline  Jerad2142
Messages: 3805
Registered: July 2006
Location: USA
Karma: 6
General (3 Stars)
Neither can I, maybe its actually a setting I hex edited for ECW (just like draw distance). Wonder if 4.X allows the user to change the particle cap with tt.ini.

Re: lod on emitters [message #489089 is a reply to message #489081] Wed, 20 August 2014 06:20 Go to previous messageGo to next message
danpaul88 is currently offline  danpaul88
Messages: 5795
Registered: June 2004
Location: England
Karma: 0
General (5 Stars)
Particle_Detail in the registry. Value range 0 - 2

I'm not sure it actually does anything though, the value gets read but then seems to go out of scope without being used. From what I can see the LoD system for particles basically caps the maximum size of particles smaller and smaller as the LoD decreases... whether it renders bigger ones smaller or just flat out erases particles larger than the current cap I'm not sure.

I suspect the particle LoD is dictated by the dynamic LoD budget, which is set via the registry.



The above is just what I can see from a quick scan through the code, it might or might not be accurate, saberhawk or jonwil would know more about it.


http://steamsignature.com/card/1/76561197975867233.png

[Updated on: Wed, 20 August 2014 06:35]

Report message to a moderator

Re: lod on emitters [message #489090 is a reply to message #489089] Wed, 20 August 2014 06:55 Go to previous messageGo to next message
Jerad2142 is currently offline  Jerad2142
Messages: 3805
Registered: July 2006
Location: USA
Karma: 6
General (3 Stars)
danpaul88 wrote on Wed, 20 August 2014 07:20

Particle_Detail in the registry. Value range 0 - 2

I'm not sure it actually does anything though, the value gets read but then seems to go out of scope without being used. From what I can see the LoD system for particles basically caps the maximum size of particles smaller and smaller as the LoD decreases... whether it renders bigger ones smaller or just flat out erases particles larger than the current cap I'm not sure.

I suspect the particle LoD is dictated by the dynamic LoD budget, which is set via the registry.



The above is just what I can see from a quick scan through the code, it might or might not be accurate, saberhawk or jonwil would know more about it.

Nah I saw that too, that's just for the slider position (3 spots, low med high).

Bet your right, I bet I just bumped the dynamic LOD budget way up (Or set it so when you move the slider in game the high value pushes it much higher).


Re: lod on emitters [message #489093 is a reply to message #489090] Wed, 20 August 2014 13:33 Go to previous messageGo to next message
roszek is currently offline  roszek
Messages: 296
Registered: June 2010
Karma: 0
Recruit
Changing these values does not seem to do anything.

Huh

[Updated on: Wed, 20 August 2014 21:08]

Report message to a moderator

Re: lod on emitters [message #489094 is a reply to message #489081] Thu, 21 August 2014 10:38 Go to previous messageGo to next message
saberhawk
Messages: 1068
Registered: January 2006
Location: ::1
Karma: 0
General (1 Star)
Dynamic LOD budget should be doing it
Re: lod on emitters [message #489095 is a reply to message #489094] Thu, 21 August 2014 20:39 Go to previous messageGo to next message
roszek is currently offline  roszek
Messages: 296
Registered: June 2010
Karma: 0
Recruit
saberhawk wrote on Thu, 21 August 2014 10:38

Dynamic LOD budget should be doing it


Not sure what I'm doing wrong but I see know difference know matter what value I change it to.
Re: lod on emitters [message #489233 is a reply to message #489081] Tue, 09 September 2014 11:22 Go to previous messageGo to next message
roszek is currently offline  roszek
Messages: 296
Registered: June 2010
Karma: 0
Recruit
I don't think this is lod I think it is a bug.
Re: lod on emitters [message #489242 is a reply to message #489233] Wed, 10 September 2014 12:48 Go to previous messageGo to next message
Jerad2142 is currently offline  Jerad2142
Messages: 3805
Registered: July 2006
Location: USA
Karma: 6
General (3 Stars)
Pictures might help.

Re: lod on emitters [message #489252 is a reply to message #489242] Thu, 11 September 2014 10:12 Go to previous messageGo to next message
roszek is currently offline  roszek
Messages: 296
Registered: June 2010
Karma: 0
Recruit
Jerad Gray wrote on Wed, 10 September 2014 12:48

Pictures might help.


I posted this vid a while ago and asked about it Huh
If you watch the emitters as I move my camera you can see what I mean.
https://www.youtube.com/watch?v=RAy8GHBVID8

My understanding is that lod is set for distance so this should not be happening?
Re: lod on emitters [message #489254 is a reply to message #489081] Thu, 11 September 2014 13:58 Go to previous message
dblaney1 is currently offline  dblaney1
Messages: 358
Registered: March 2014
Location: United States
Karma: 0
Commander
Yeah thats an annoying glitch sometimes happens with the mesh level of detail as well. Quite annoying. I hope it can be fixed.
Previous Topic: First person view gun animation
Next Topic: Nod 15 Inch Coastal Defense Gun
Goto Forum:
  


Current Time: Sat May 18 00:07:22 MST 2024

Total time taken to generate the page: 0.00930 seconds