Renegade Public Forums
C&C: Renegade --> Dying since 2003™, resurrected in 2024!
Home » Tiberian Technologies / Blackhand Studios » Tiberian Technologies Forum » Partial Ion Cannon Rings since 4.X Release
Partial Ion Cannon Rings since 4.X Release [message #488214] Tue, 01 July 2014 11:22 Go to next message
Jerad2142 is currently offline  Jerad2142
Messages: 3805
Registered: July 2006
Location: USA
Karma: 6
General (3 Stars)
This might have occurred in 4.0, but it definitely happens on both by Intel laptop and Nvidia PC. Back in 3.4.4 the Ion cannon rings were full, and now they're always partial.
index.php?t=getfile&id=14969&private=0
index.php?t=getfile&id=14970&private=0


Re: Partial Ion Cannon Rings since 4.X Release [message #488264 is a reply to message #488214] Wed, 02 July 2014 05:58 Go to previous messageGo to next message
Jerad2142 is currently offline  Jerad2142
Messages: 3805
Registered: July 2006
Location: USA
Karma: 6
General (3 Stars)
So I opened up the Ion cannon pre animation file (xg_ag_ionc_p1) and found that the ring is apparently done with Primitives (which I found surprising because I had never seen a primitive, except apparently this one, actually work in pre 4.0, I do remember that being one of my first statements "wow, primitives are working). The thing I find odd is the primitive effect in 4.1 seems to have way more detail than the actual effect (There appears to be an arching effect going on, where as the original is just a smooth blur), so maybe the 4.x effect got patched?

As you can see from this video, this is how it looked in stock Ren:
http://www.youtube.com/watch?v=fcbyzH4xJ5o&feature=player_detailpage#t=66

Here is the original ion cannon effects btw, I glanced into 4.X's files but I don't see any different ones either.
  • Attachment: Ion.zip
    (Size: 1.43KB, Downloaded 78 times)


Re: Partial Ion Cannon Rings since 4.X Release [message #488265 is a reply to message #488214] Wed, 02 July 2014 07:10 Go to previous messageGo to next message
danpaul88 is currently offline  danpaul88
Messages: 5795
Registered: June 2004
Location: England
Karma: 0
General (5 Stars)
Primitives are a pain in the ass for code that wants to parse W3D files too since they have their own "special" node types that don't conform to node types of the parent document. I ran into that problem with some code I was writing that choked on chunk types of 1 which were not actually chunk types of 1 but primitive special chunks of type 1 which are entirely different data structures.

I'm not sure but I suspect they are a legacy feature which wasn't used extensively in the engine, except for a few select things like the ion stuff.


http://steamsignature.com/card/1/76561197975867233.png

[Updated on: Wed, 02 July 2014 07:11]

Report message to a moderator

Re: Partial Ion Cannon Rings since 4.X Release [message #488266 is a reply to message #488214] Wed, 02 July 2014 07:14 Go to previous messageGo to next message
jonwil is currently offline  jonwil
Messages: 3555
Registered: February 2003
Karma: 0
General (3 Stars)

Turns out some code we had for Ring and Sphere primitives is broken. Its fixed going forward (i.e. mods etc) now and if any future releases are made for Renegade, this fix can be back-ported Smile


Jonathan Wilson aka Jonwil
Creator and Lead Coder of the Custom scripts.dll
Renegade Engine Guru
Creator and Lead Coder of TT.DLL
Official member of Tiberian Technologies
Re: Partial Ion Cannon Rings since 4.X Release [message #488267 is a reply to message #488266] Wed, 02 July 2014 07:18 Go to previous message
Jerad2142 is currently offline  Jerad2142
Messages: 3805
Registered: July 2006
Location: USA
Karma: 6
General (3 Stars)
However in all fairness you guys fixed far more than was broke, before 4.0 most the primitive stuff didn't work (originally I didn't think any of it worked, but I guess the ion cannon was a magical special case that does work). So Coddles for that!

I remember going through the painful process of wwskinning bones to a sphere just so I could make a shock wave effect because primitives didn't work for me lol.


So beings you mention a lot of fixes, I suppose its pointless to ask if the garbage that sometimes appears on screen (normally in the lower right hand corner) is fixed (I see it a lot when I blow up sam sites at a distance, happens on both my laptop and my main computer).


[Updated on: Wed, 02 July 2014 07:22]

Report message to a moderator

Previous Topic: Set_Face_Location no longer makes AI VTOLs strafe
Next Topic: Error code from a Jelly member
Goto Forum:
  


Current Time: Sat May 18 01:01:20 MST 2024

Total time taken to generate the page: 0.00632 seconds