Renegade Public Forums
C&C: Renegade --> Dying since 2003™, resurrected in 2024!
Home » Tiberian Technologies / Blackhand Studios » Tiberian Technologies Forum » TT scripts run error - Service Pack 3?
TT scripts run error - Service Pack 3? [message #487808] Tue, 10 June 2014 15:43 Go to next message
w34g is currently offline  w34g
Messages: 7
Registered: December 2004
Karma: 0
Recruit
I have installed renegade on my computer through the first decade.
I downloaded TTscripts 4.1 from their website and have followed tutorials and searched all over the internet for a solution but nothing has worked.

The install works fine, then I click to run the game and it tells me it is installing an update.

After it updates, an error comes up that says
"Renegade cannot run on this computer because it requires Windows XP Service Pack 3 or higher"

I have tried to install SP3 on my computer, but apparantly it won't work either... it says "This Service Pack 3 is for a different hardware platform"


Any help?

[Updated on: Tue, 10 June 2014 15:53]

Report message to a moderator

Re: TT scripts run error - Service Pack 3? [message #487810 is a reply to message #487808] Tue, 10 June 2014 17:12 Go to previous messageGo to next message
Xpert is currently offline  Xpert
Messages: 1588
Registered: December 2005
Location: New York City
Karma: 0
General (1 Star)
w34g wrote on Tue, 10 June 2014 18:43

I have installed renegade on my computer through the first decade.
I downloaded TTscripts 4.1 from their website and have followed tutorials and searched all over the internet for a solution but nothing has worked.

The install works fine, then I click to run the game and it tells me it is installing an update.

After it updates, an error comes up that says
"Renegade cannot run on this computer because it requires Windows XP Service Pack 3 or higher"

I have tried to install SP3 on my computer, but apparantly it won't work either... it says "This Service Pack 3 is for a different hardware platform"


Any help?


What are the specs of your computer? What OS do you currently run? Also, are you a player on Jelly server that got kicked and forced to run 4.0 (just curious).


http://i32.photobucket.com/albums/d42/XpertMaverick/xpertyankee.jpg

Creator of NetGuard, an IRC network regulator.
Developer of the CloudyServ 0.982-X project.
Developer of the CloudyServ Ren-X bot.

Part time streamer - https://twitch.tv/gg_wonder
Re: TT scripts run error - Service Pack 3? [message #487814 is a reply to message #487808] Tue, 10 June 2014 19:16 Go to previous messageGo to next message
w34g is currently offline  w34g
Messages: 7
Registered: December 2004
Karma: 0
Recruit
I am running Windows 7 ultimate
Model: Studio XPS 8000
Intel Core i5 CPU 750 @ 2.67 GHz
Ram 6GB
System type 64bit


Not sure if there are any other specs you might be looking for.
I am not running anything fishy I just put the disc in and want to play again- feeling nostalgic.
Re: TT scripts run error - Service Pack 3? [message #487816 is a reply to message #487808] Tue, 10 June 2014 20:02 Go to previous messageGo to next message
jonwil is currently offline  jonwil
Messages: 3555
Registered: February 2003
Karma: 0
General (3 Stars)

My guess is that you have some "Compatibility Mode" settings set on Renegade somehow and that's whats causing the error.


Jonathan Wilson aka Jonwil
Creator and Lead Coder of the Custom scripts.dll
Renegade Engine Guru
Creator and Lead Coder of TT.DLL
Official member of Tiberian Technologies
Re: TT scripts run error - Service Pack 3? [message #487817 is a reply to message #487808] Tue, 10 June 2014 20:22 Go to previous messageGo to next message
Xpert is currently offline  Xpert
Messages: 1588
Registered: December 2005
Location: New York City
Karma: 0
General (1 Star)
Try running the 4.0/4.1 installer in admin mode also.

http://i32.photobucket.com/albums/d42/XpertMaverick/xpertyankee.jpg

Creator of NetGuard, an IRC network regulator.
Developer of the CloudyServ 0.982-X project.
Developer of the CloudyServ Ren-X bot.

Part time streamer - https://twitch.tv/gg_wonder
Re: TT scripts run error - Service Pack 3? [message #487818 is a reply to message #487808] Tue, 10 June 2014 20:32 Go to previous messageGo to next message
w34g is currently offline  w34g
Messages: 7
Registered: December 2004
Karma: 0
Recruit
I have run everything in admin mode.

Also, what compatibility settings would be causing this?
I have tried messing around with the settings as much as possible, but I'm not as computer savvy as I used to be.
Re: TT scripts run error - Service Pack 3? [message #487819 is a reply to message #487808] Wed, 11 June 2014 04:37 Go to previous messageGo to next message
iRANian is currently offline  iRANian
Messages: 4299
Registered: April 2011
Karma: 0
General (4 Stars)
Probably Windows XP / Service Pack 1 / Service Pack 2 compatibility. Just turn off compatibility on Game.exe, Game2.exe, Renegade.exe, UAC Launcher.exe or whatever other EXE or shortcut you are using.

Long time and well respected Renegade community member, programmer, modder and tester.

Scripts 4.0 private beta tester since May 2011.

My Renegade server plugins releases
Re: TT scripts run error - Service Pack 3? [message #487820 is a reply to message #487808] Wed, 11 June 2014 09:47 Go to previous messageGo to next message
w34g is currently offline  w34g
Messages: 7
Registered: December 2004
Karma: 0
Recruit
iRANian is right.

If anyone else has this issue, what I had to do was go into my renegade folder and right click-m properties- compatibility- switch everything to Windows 7.
Including shortcuts and installers.

It works now!
Re: TT scripts run error - Service Pack 3? [message #487826 is a reply to message #487820] Thu, 12 June 2014 10:04 Go to previous message
saberhawk
Messages: 1068
Registered: January 2006
Location: ::1
Karma: 0
General (1 Star)
w34g wrote on Wed, 11 June 2014 09:47

iRANian is right.

If anyone else has this issue, what I had to do was go into my renegade folder and right click-m properties- compatibility- switch everything to Windows 7.
Including shortcuts and installers.

It works now!


You shouldn't need *any* compatibility mode; this includes running as admin.
Previous Topic: TT Level Edit bug
Next Topic: Crashes
Goto Forum:
  


Current Time: Sat Apr 13 20:57:27 MST 2024

Total time taken to generate the page: 0.00724 seconds