Renegade Public Forums
C&C: Renegade --> Dying since 2003™, resurrected in 2024!
Home » Tiberian Technologies / Blackhand Studios » Other Products » BrenBot error
BrenBot error [message #487764] Wed, 04 June 2014 15:40 Go to next message
Jerad2142 is currently offline  Jerad2142
Messages: 3805
Registered: July 2006
Location: USA
Karma: 6
General (3 Stars)
So I recently started getting this error, I would assume it was related to GameSpy going doing but from what I've heard its still up.
index.php?t=getfile&id=14950&private=0
  • Attachment: perlError.png
    (Size: 44.84KB, Downloaded 370 times)


Re: BrenBot error [message #487765 is a reply to message #487764] Wed, 04 June 2014 16:25 Go to previous messageGo to next message
Ethenal is currently offline  Ethenal
Messages: 2532
Registered: January 2007
Location: US of A
Karma: 0
General (2 Stars)

Maybe try deleting that folder in %TMP% first? It may simply be that it did not unpack the scripts correctly. It's happened to me before.

-TLS-DJ-EYE-K wrote on Mon, 18 March 2013 07:29

Instead of showing us that u aren't more inteligent than a Toast, maybe you should start becomming good in renegade Thumbs Up

Re: BrenBot error [message #487766 is a reply to message #487764] Wed, 04 June 2014 23:51 Go to previous messageGo to next message
danpaul88 is currently offline  danpaul88
Messages: 5795
Registered: June 2004
Location: England
Karma: 0
General (5 Stars)
Yes, that bug is in par, the toolkit used to turn BRenBot into an exe file. It happens sometimes, especially if you kill the process halfway through unpacking and then run it again, it doesn't verify the integrity of the temp folder if it exists already.

http://steamsignature.com/card/1/76561197975867233.png
Re: BrenBot error [message #487772 is a reply to message #487764] Thu, 05 June 2014 16:38 Go to previous messageGo to next message
Gen_Blacky is currently offline  Gen_Blacky
Messages: 3250
Registered: September 2006
Karma: 1
General (3 Stars)
I remember experiencing that problem

After I included certain libs in the pp command line the problem never happened again.

pp -o=BRENBOT.exe -v -M XML::SAX::Expat

or i just never seen them since lol


http://s18.postimage.org/jc6qbn4k9/bricks3.png

[Updated on: Thu, 05 June 2014 16:41]

Report message to a moderator

Re: BrenBot error [message #487774 is a reply to message #487764] Thu, 05 June 2014 21:07 Go to previous messageGo to next message
Ethenal is currently offline  Ethenal
Messages: 2532
Registered: January 2007
Location: US of A
Karma: 0
General (2 Stars)

I had to do that with a couple of things when compiling it myself, but that's a different problem from what danpaul is talking about. If you start BRenBot and it starts unpacking itself, it doesn't display anything so you might think it's frozen... if you close it while it's starting, it stops unpacking immediately. So the next time you start it, it will likely complain that the last file it was unpacking is corrupt.

-TLS-DJ-EYE-K wrote on Mon, 18 March 2013 07:29

Instead of showing us that u aren't more inteligent than a Toast, maybe you should start becomming good in renegade Thumbs Up

[Updated on: Thu, 05 June 2014 21:07]

Report message to a moderator

Re: BrenBot error [message #487775 is a reply to message #487764] Fri, 06 June 2014 01:48 Go to previous message
danpaul88 is currently offline  danpaul88
Messages: 5795
Registered: June 2004
Location: England
Karma: 0
General (5 Stars)
Indeed, that is exactly what happens.

On the related subject of packing up a modified BRenBot, the command line I use for pp is on the SVN in the Documentation folder, but for reference it is;

pp -o brenbot.exe -M POE/Filter.pm -M POE/Filter/Stream.pm -M XML/LibXML/Sax.pm -l libexpat-1_.dll -l libxml2-2_.dll -l libiconv-2_.dll -l liblzma-5_.dll -l zlib1_.dll brenbot.pl


http://steamsignature.com/card/1/76561197975867233.png
Previous Topic: Certain gamelogs
Next Topic: Brenbot killme plugin?
Goto Forum:
  


Current Time: Fri May 17 23:42:32 MST 2024

Total time taken to generate the page: 0.00631 seconds