Renegade Public Forums
C&C: Renegade --> Dying since 2003™, resurrected in 2024!
Home » Renegade Discussions » Mod Forum » Help requested! :) - Vehicle animations
Help requested! :) - Vehicle animations [message #487391] Sun, 27 April 2014 15:39 Go to next message
UnitXc is currently offline  UnitXc
Messages: 116
Registered: March 2009
Karma: 0
Recruit
hi. about 6 years ago i made some models for fun that were fps versions of C&C generals vehicles, there happened to be a mod going for renegade with that ambition, and i joined it for a short time before uni took over.

I recently found the old 3ds max files i used to make them and updated them with textures (i didnt know how to texture back then)

I want to implement the Gatling tank into future maps I make but im stumped as to how I

1. rig the tank so it can go into renegade.
2. animate the tank to make the barrels spin when shooting

ive done maps, but i dont know how to do vehicles so thats the next thing i want to tackle, simply because its fun Smile

Pretty pictures
http://i.imgur.com/lChEA82.png
http://i.imgur.com/lCK7MGY.pnghttp://i.imgur.com/tYALFW0.png
http://i.imgur.com/KysRdnv.pnghttp://i.imgur.com/J4Agaso.png


http://i423.photobucket.com/albums/pp318/UnitXc/UnitXcSiggy.jpg
Re: Help requested! :) - Vehicle animations [message #487392 is a reply to message #487391] Sun, 27 April 2014 15:59 Go to previous messageGo to next message
NACHO-ARG is currently offline  NACHO-ARG
Messages: 397
Registered: October 2010
Karma: 0
Commander
chek out this tutorials:

http://renhelp.laeubi.de/tutorial-boning-vehicles.html

http://renhelp.laeubi.de/tutorial-how-to-cunstruct-a-renegade-vehicle.html

http://renhelp.laeubi.de/tutorial-vehicle-help.html
Re: Help requested! :) - Vehicle animations [message #487393 is a reply to message #487391] Sun, 27 April 2014 17:24 Go to previous messageGo to next message
liquidv2 is currently offline  liquidv2
Messages: 3407
Registered: February 2007
Karma: 0
General (3 Stars)
boning vehicles? Unit's all over that

liquidv2
Re: Help requested! :) - Vehicle animations [message #487394 is a reply to message #487391] Sun, 27 April 2014 18:49 Go to previous messageGo to next message
UnitXc is currently offline  UnitXc
Messages: 116
Registered: March 2009
Karma: 0
Recruit
these tutorials dont tell me how to make the vehicle if i want parts to move later on.

only how to make one where everyhing is static.

Sad


http://i423.photobucket.com/albums/pp318/UnitXc/UnitXcSiggy.jpg
Re: Help requested! :) - Vehicle animations [message #487398 is a reply to message #487394] Mon, 28 April 2014 09:51 Go to previous messageGo to next message
Jerad2142 is currently offline  Jerad2142
Messages: 3805
Registered: July 2006
Location: USA
Karma: 6
General (3 Stars)
Click the animation button at the bottom of the gmax/3dsmax, then move the animation slider to the frame you want to animate, rotate/move the parts you want the way you want them.

Export with animations

Success.
Animation name would be:
ModelName.ModelName


For more complex things you export the model as "Hierarchical Model" then you export again as "Pure Animation" naming the animations what you want, each time selecting the "Hierarchical Model" as the skeleton of the "Pure Animation"

Animation Name would be:
HierarchicalModel.PureAnimation


[Updated on: Mon, 28 April 2014 09:53]

Report message to a moderator

Re: Help requested! :) - Vehicle animations [message #487401 is a reply to message #487391] Mon, 28 April 2014 12:57 Go to previous messageGo to next message
UnitXc is currently offline  UnitXc
Messages: 116
Registered: March 2009
Karma: 0
Recruit
so does that mean i export the model once as a "hierarchical model" without any animation as for example Gattank.w3d

and then export a second clone of the first as "Hierarchical Animated model" with the animation of the barrels spinning as like Gattank_spin.w3d

?

i wouldnt want the animation to be playing all the time.. :S how does it know when to do what..


http://i423.photobucket.com/albums/pp318/UnitXc/UnitXcSiggy.jpg

[Updated on: Mon, 28 April 2014 12:58]

Report message to a moderator

Re: Help requested! :) - Vehicle animations [message #487402 is a reply to message #487391] Mon, 28 April 2014 17:10 Go to previous messageGo to next message
jonwil is currently offline  jonwil
Messages: 3555
Registered: February 2003
Karma: 0
General (3 Stars)

You need scripting to make the barrel-rotates-when-shooting work. Not sure which script is the right one for that off the top of my head but there is definatly one available in scripts 4.1.


Jonathan Wilson aka Jonwil
Creator and Lead Coder of the Custom scripts.dll
Renegade Engine Guru
Creator and Lead Coder of TT.DLL
Official member of Tiberian Technologies
Re: Help requested! :) - Vehicle animations [message #487403 is a reply to message #487391] Mon, 28 April 2014 17:33 Go to previous messageGo to next message
UnitXc is currently offline  UnitXc
Messages: 116
Registered: March 2009
Karma: 0
Recruit
some people say no scripting, others say yes scripting.

its fine needing a script, but i need to know how to rig the model so it can use the animation, then i need to know what and how to export it propperly, then i need to know which script to use. and then i need to know all the fiddly bits of the script in question, what its looking for what to type in the fields, what not to type.

Sad

first, i need to know how to rig the model.


http://i423.photobucket.com/albums/pp318/UnitXc/UnitXcSiggy.jpg
Re: Help requested! :) - Vehicle animations [message #487404 is a reply to message #487402] Tue, 29 April 2014 00:27 Go to previous messageGo to next message
danpaul88 is currently offline  danpaul88
Messages: 5795
Registered: June 2004
Location: England
Karma: 0
General (5 Stars)

jonwil wrote on Tue, 29 April 2014 01:10

You need scripting to make the barrel-rotates-when-shooting work. Not sure which script is the right one for that off the top of my head but there is definatly one available in scripts 4.1.



Can't he just use the fire animation on the vehicle preset? I thought that was fixed in 4.0?


http://steamsignature.com/card/1/76561197975867233.png
Re: Help requested! :) - Vehicle animations [message #487405 is a reply to message #487391] Tue, 29 April 2014 01:29 Go to previous messageGo to next message
Mauler
Messages: 448
Registered: May 2003
Location: Alberta, Canada
Karma: 0
Commander
It is not.. We have tried that..
Re: Help requested! :) - Vehicle animations [message #487408 is a reply to message #487405] Tue, 29 April 2014 08:42 Go to previous messageGo to next message
Jerad2142 is currently offline  Jerad2142
Messages: 3805
Registered: July 2006
Location: USA
Karma: 6
General (3 Stars)
Mauler wrote on Tue, 29 April 2014 02:29

It is not.. We have tried that..

I had it work the other day, I just had to make Fire1Anim(or possibly just the animation) play the stopped animation.

Try LE settings like this:
Animation:
tank.stopped

Fire0Anim:
tank.fire

Fire1Anim:
tank.stopped

(Its possible that it fell apart, but I could have sworn it worked at one point during 4.0).


[Updated on: Tue, 29 April 2014 08:45]

Report message to a moderator

Re: Help requested! :) - Vehicle animations [message #487409 is a reply to message #487391] Tue, 29 April 2014 08:45 Go to previous messageGo to next message
Gen_Blacky is currently offline  Gen_Blacky
Messages: 3250
Registered: September 2006
Karma: 1
General (3 Stars)
yea the model just needs a 1 frame animation and it should work in le.

you can also use that raven_vehicle_animation or similar scripts.


http://s18.postimage.org/jc6qbn4k9/bricks3.png
Re: Help requested! :) - Vehicle animations [message #487411 is a reply to message #487391] Tue, 29 April 2014 09:18 Go to previous messageGo to next message
UnitXc is currently offline  UnitXc
Messages: 116
Registered: March 2009
Karma: 0
Recruit
well we got everything working after spending an all nighter on it.

the sad thing is that in my fatigue i just broke it again. but not before i was able to take this fraps video.

https://www.youtube.com/watch?v=-Zn1e7qeUxY


http://i423.photobucket.com/albums/pp318/UnitXc/UnitXcSiggy.jpg
Re: Help requested! :) - Vehicle animations [message #487418 is a reply to message #487391] Tue, 29 April 2014 12:43 Go to previous messageGo to next message
Mauler
Messages: 448
Registered: May 2003
Location: Alberta, Canada
Karma: 0
Commander
Haha nice one! I'm sure you just buggered a setting.. gimme a shout IRC I can give you a hand to fix er' up Thumbs Up

[Updated on: Tue, 29 April 2014 12:43]

Report message to a moderator

Re: Help requested! :) - Vehicle animations [message #487419 is a reply to message #487408] Tue, 29 April 2014 12:45 Go to previous messageGo to next message
Mauler
Messages: 448
Registered: May 2003
Location: Alberta, Canada
Karma: 0
Commander
Jerad Gray wrote on Tue, 29 April 2014 09:42

Mauler wrote on Tue, 29 April 2014 02:29

It is not.. We have tried that..

I had it work the other day, I just had to make Fire1Anim(or possibly just the animation) play the stopped animation.

Try LE settings like this:
Animation:
tank.stopped

Fire0Anim:
tank.fire

Fire1Anim:
tank.stopped

(Its possible that it fell apart, but I could have sworn it worked at one point during 4.0).


Yeah we tried that but using that LE setting only gave us one frame of the animation we made for it.. so it did work just only with one frame playing and then it would stop haha..
Re: Help requested! :) - Vehicle animations [message #487423 is a reply to message #487409] Tue, 29 April 2014 17:03 Go to previous messageGo to next message
Mauler
Messages: 448
Registered: May 2003
Location: Alberta, Canada
Karma: 0
Commander
Gen_Blacky wrote on Tue, 29 April 2014 09:45

yea the model just needs a 1 frame animation and it should work in le.

you can also use that raven_vehicle_animation or similar scripts.


Yeah we got it working using the Raven scripts... Both Primary and Secondary now have animated rotating barrels
Re: Help requested! :) - Vehicle animations [message #487440 is a reply to message #487391] Thu, 01 May 2014 02:17 Go to previous messageGo to next message
UnitXc is currently offline  UnitXc
Messages: 116
Registered: March 2009
Karma: 0
Recruit
aye and its really cool, though the animation doesnt work on FDS without some major tweeks im told.

which is unfortunate Sad

Mauler is however debugging it and hopefully all will end well.

after that I intend to release the tanks to the public


http://i423.photobucket.com/albums/pp318/UnitXc/UnitXcSiggy.jpg
Re: Help requested! :) - Vehicle animations [message #487443 is a reply to message #487391] Thu, 01 May 2014 04:20 Go to previous messageGo to next message
danpaul88 is currently offline  danpaul88
Messages: 5795
Registered: June 2004
Location: England
Karma: 0
General (5 Stars)
You also have to consider that scripts run server side and thus there will always be lag between "press fire" and the animation actually happening... and ditto for stopping the animation.

http://steamsignature.com/card/1/76561197975867233.png
Re: Help requested! :) - Vehicle animations [message #487455 is a reply to message #487391] Thu, 01 May 2014 10:05 Go to previous message
Mauler
Messages: 448
Registered: May 2003
Location: Alberta, Canada
Karma: 0
Commander
I've got it working. Thanks to some information from my friend roszek.. Has made it work using a uncoventional method but it was successful.. As Danpaul said there will be some lag input but that is to be expected

[Updated on: Thu, 01 May 2014 10:07]

Report message to a moderator

Previous Topic: .w3d view
Next Topic: C&C_AlpineDrop
Goto Forum:
  


Current Time: Mon Apr 22 21:38:23 MST 2024

Total time taken to generate the page: 0.01049 seconds