Renegade Public Forums
C&C: Renegade --> Dying since 2003™, resurrected in 2024!
Home » Tiberian Technologies / Blackhand Studios » Tiberian Technologies Forum » Map errors with 4.1
Map errors with 4.1 [message #485839] Sat, 08 February 2014 20:35 Go to next message
Mauler
Messages: 448
Registered: May 2003
Location: Alberta, Canada
Karma: 0
Commander
So as you may know UltraAOW runs custom maps in it's rotation and as of 4.0 everything was running fine, however now with 4.1 RC2 the server has apparently caught some issues..


First is the Nod cargo plane seems to destroyable or has completely disappeared in the 4.1 update



Second, Seems like some custom maps have issues with pathfinding where there was none before in 4.0



Lastly LDD files seem to not properly load, As we required a custom LDD file for a fix to one of our maps, the modified LDD file was used to correct the position of the GDI weapons factory spawn point.. as the mammoth would spawn with it's main turret inside the WF doors.. we placed a LDD file into the server files and it fixed our issue and was fine with 4.0... something seems to have broken with 4.1 cause we are now having issues with that again..

Re: Map errors with 4.1 [message #485848 is a reply to message #485839] Sun, 09 February 2014 01:03 Go to previous messageGo to next message
Gen_Blacky is currently offline  Gen_Blacky
Messages: 3250
Registered: September 2006
Karma: 1
General (3 Stars)
You should rebuild all your custom maps with the 4.1 mod tools.

http://s18.postimage.org/jc6qbn4k9/bricks3.png
Re: Map errors with 4.1 [message #485863 is a reply to message #485839] Sun, 09 February 2014 04:21 Go to previous messageGo to next message
jonwil is currently offline  jonwil
Messages: 3555
Registered: February 2003
Karma: 0
General (3 Stars)

Rebuilding the maps is not necessary.
What I need is exact reproduction steps for the cargo plane issue and the pathfinding problem.


Jonathan Wilson aka Jonwil
Creator and Lead Coder of the Custom scripts.dll
Renegade Engine Guru
Creator and Lead Coder of TT.DLL
Official member of Tiberian Technologies
Re: Map errors with 4.1 [message #485864 is a reply to message #485839] Sun, 09 February 2014 04:23 Go to previous messageGo to next message
Mauler
Messages: 448
Registered: May 2003
Location: Alberta, Canada
Karma: 0
Commander
Me and zunnie thought it might of been a issue with the loading of an external LDD file that caused the pathfinding info and carmarker to break and have the mammoth get stuck in the doors?
Re: Map errors with 4.1 [message #485865 is a reply to message #485839] Sun, 09 February 2014 04:29 Go to previous messageGo to next message
danpaul88 is currently offline  danpaul88
Messages: 5795
Registered: June 2004
Location: England
Karma: 0
General (5 Stars)
tsr pathfinding got broken on some maps when we updated to 4.1 too, I had to regen it in LE to stop harvesters crashing into walls after their first dump. Looks like the problem is more widespread...

http://steamsignature.com/card/1/76561197975867233.png
Re: Map errors with 4.1 [message #485910 is a reply to message #485839] Mon, 10 February 2014 03:53 Go to previous messageGo to next message
jonwil is currently offline  jonwil
Messages: 3555
Registered: February 2003
Karma: 0
General (3 Stars)

Nothing affecting pathfinding was changed in leveledit, therefore if rebuilding pathfinding with 4.1 somehow gives you a different result to what 4.0 did, that's unintentional (and may in fact indicate something we need to look into)

As for the .ldd issue, I just ran a test:
1.Put 4.1 on my test FDS
2.Extracted C&C_Field.ldd into my data folder.
3.Started my test FDS in the debugger (with C&C_Field as the loaded map)
4.Confirmed that it was loading C&C_Field.ldd from the data folder and not from C&C_Field.mix
5.Repeated the test using C&C_Aitest.mix (in case the stock maps somehow perform different to custom maps)
6.Confirmed that it was loading C&C_Aitest.ldd from the data folder and not from C&C_Aitest.mix

So as of right now I am unable to reproduce the issue. If someone who is able to reproduce the problem could contact me on IRC/IM so I can go through some debugging stuff, that would be great.


Jonathan Wilson aka Jonwil
Creator and Lead Coder of the Custom scripts.dll
Renegade Engine Guru
Creator and Lead Coder of TT.DLL
Official member of Tiberian Technologies
Re: Map errors with 4.1 [message #485912 is a reply to message #485839] Mon, 10 February 2014 04:24 Go to previous messageGo to next message
danpaul88 is currently offline  danpaul88
Messages: 5795
Registered: June 2004
Location: England
Karma: 0
General (5 Stars)
The problem as far as I can see it is this;

- Map pathfinding was generated in 4.0 and earlier
- Harvesters pathfinding worked perfectly
- Client updates to 4.1, map files unchanged
- Harvesters now crashing into walls all over the place on SOME maps, but not all. Sometimes only one of the two harvesters would crash
- Regen pathfind with 4.1 LE, re-export map
- Harvesters working properly again


I suspect the waypaths are somehow becoming detached from the pathfind grid or otherwise failing to be detected by the harvester so it tries to "bee-line" its way to where it wants to be, which sends it crashing into a wall.




You can get a copy of the broken maps from TSR by editing the registry and setting the version number in HKLM/Software/Bluehell/TSRClient to 1.1.0.0. Run the launcher, right click on TSR and choose repair, it'll reinstall that version of TSR. Then launch TS_Crossroads and watch the Nod harvester after its first dump, it should crash into one of the destructable walls instead of going around the front of them.

Change the version number again to 1.0.5.5 and repair it again. This is the SAME map, but prior to 4.1. The pathfinding now works correctly.


http://steamsignature.com/card/1/76561197975867233.png

[Updated on: Mon, 10 February 2014 04:29]

Report message to a moderator

Re: Map errors with 4.1 [message #485918 is a reply to message #485839] Mon, 10 February 2014 05:04 Go to previous messageGo to next message
jonwil is currently offline  jonwil
Messages: 3555
Registered: February 2003
Karma: 0
General (3 Stars)

do you happen to know which reborn version was the first one with the "works in 4.1" map?
I will probably do 2 things to investigate this, one being code regressiom testing to see what made it stop working in build 1.1.1.0 and the second being file comparisons of the lsd/ldd files between the "works in 4.1" msp and the broken one to see whats different between the two that would make it work

both things will help narrow down any bug(s) that exist in the pathfindiing code.


Jonathan Wilson aka Jonwil
Creator and Lead Coder of the Custom scripts.dll
Renegade Engine Guru
Creator and Lead Coder of TT.DLL
Official member of Tiberian Technologies
Re: Map errors with 4.1 [message #485920 is a reply to message #485839] Mon, 10 February 2014 06:50 Go to previous messageGo to next message
danpaul88 is currently offline  danpaul88
Messages: 5795
Registered: June 2004
Location: England
Karma: 0
General (5 Stars)
1.1.1.5 (the current public version) is the first "works in 4.1" version of that map as I recall, but I'm not sure it'll be much help since I actually redid the zones and whatnot on TS_Crossroads for a different reason at the same time I was fixing it.

I believe you can see the same problem on TS_Snow, with the Nod harvester getting stuck on the edge of the gate in the 1.1.0.0 version and working in 1.1.1.5 after only re-doing pathfind.



When I'm home from work I'll be able to grab the "broken" maps individually from the FTP server so you can just drop them on top of the current version and compare, so if you need me to do that give me a shout on Skype in about 5 hours or so, if you're still up, or leave me a task on Trello or something.


http://steamsignature.com/card/1/76561197975867233.png

[Updated on: Mon, 10 February 2014 07:00]

Report message to a moderator

Re: Map errors with 4.1 [message #485932 is a reply to message #485839] Mon, 10 February 2014 11:03 Go to previous messageGo to next message
Xpert is currently offline  Xpert
Messages: 1588
Registered: December 2005
Location: New York City
Karma: 0
General (1 Star)
We have users who use 4.1 on Jelly. The Cargo Plane issue apparently isn't server side.

One of our players said he sees the cargo plane for a split second then it disappears then reappears and disappears again.


http://i32.photobucket.com/albums/d42/XpertMaverick/xpertyankee.jpg

Creator of NetGuard, an IRC network regulator.
Developer of the CloudyServ 0.982-X project.
Developer of the CloudyServ Ren-X bot.

Part time streamer - https://twitch.tv/gg_wonder
Re: Map errors with 4.1 [message #485947 is a reply to message #485839] Mon, 10 February 2014 16:27 Go to previous messageGo to next message
jonwil is currently offline  jonwil
Messages: 3555
Registered: February 2003
Karma: 0
General (3 Stars)

What I need are the scripts build number/version/details/build files from 1.0.5.5 (the last good version), the scripts build number/version/details/build files from 1.1.1.0 (the version that broke things), the broken TS_Snow map (from 1.0.5.5/1.1.1.0) and the working TS_Snow map (from 1.1.1.5)


Jonathan Wilson aka Jonwil
Creator and Lead Coder of the Custom scripts.dll
Renegade Engine Guru
Creator and Lead Coder of TT.DLL
Official member of Tiberian Technologies
Re: Map errors with 4.1 [message #486078 is a reply to message #485839] Thu, 13 February 2014 22:31 Go to previous messageGo to next message
jonwil is currently offline  jonwil
Messages: 3555
Registered: February 2003
Karma: 0
General (3 Stars)

After checking with StealthEye, I can confirm that if you have a map in the TTFS (i.e. available to be downloaded to the client) then files in the TTFS (including .ldd files) will override any files local in the data folder. The solution (per what StealthEye said) is to update the TTFS package with a new map version containing the fixed ldd file.


Jonathan Wilson aka Jonwil
Creator and Lead Coder of the Custom scripts.dll
Renegade Engine Guru
Creator and Lead Coder of TT.DLL
Official member of Tiberian Technologies
Re: Map errors with 4.1 [message #486086 is a reply to message #485839] Fri, 14 February 2014 07:51 Go to previous messageGo to next message
zunnie is currently offline  zunnie
Messages: 2959
Registered: September 2003
Location: Netherlands
Karma: 0
General (2 Stars)

That effectively disables people from running serverside mods for maps specific. Or small fixes that were made to a map that would otherwise not be able to run properly. Maps for which people don't have the source.

https://multiplayerforums.com/uploads/monthly_2018_03/TCW2_Signature.png.6236a0dbc6e1e53472a18fe8cd15e47b.png
Re: Map errors with 4.1 [message #486093 is a reply to message #485839] Fri, 14 February 2014 11:30 Go to previous messageGo to next message
StealthEye is currently offline  StealthEye
Messages: 2518
Registered: May 2006
Location: The Netherlands
Karma: 0
General (2 Stars)

Just add another package to the game definition that overrides the desired files.

Alternatively, you can get the map's files by clearing your ttfs, downloading that specific map, and copying all files from ttfs to somewhere else. You'll just have to remove the map hashes for the map to be working again (and perhaps sometimes fix files that used to be in subdirs).


BlackIntel admin/founder/coder
Please visit http://www.blackintel.org/
Re: Map errors with 4.1 [message #486094 is a reply to message #486093] Fri, 14 February 2014 11:40 Go to previous messageGo to next message
Jerad2142 is currently offline  Jerad2142
Messages: 3805
Registered: July 2006
Location: USA
Karma: 6
General (3 Stars)
I know you said the server now tries to block ID collision issues, what happens if one of these harvester waypaths had a waypoint ID that collided with an object on the level?

By the way, from my experience the harvester only uses pathfind to get to the start of the waypath, once following the waypath they'll follow it into walls or loop in circles if the user made the path to do so, so I doubt it is a pathfind issue unless the creator did something weird with the waypath (like starting it half a mile away from the warfactory/refinery).


Re: Map errors with 4.1 [message #486096 is a reply to message #485839] Fri, 14 February 2014 11:43 Go to previous messageGo to next message
zunnie is currently offline  zunnie
Messages: 2959
Registered: September 2003
Location: Netherlands
Karma: 0
General (2 Stars)

I'll have to rebuild the maps from scratch that we fixed then and save them under a different name and place them on the TTFS i guess. A lot of work but oh well.

https://multiplayerforums.com/uploads/monthly_2018_03/TCW2_Signature.png.6236a0dbc6e1e53472a18fe8cd15e47b.png
Re: Map errors with 4.1 [message #486115 is a reply to message #485839] Fri, 14 February 2014 14:03 Go to previous messageGo to next message
danpaul88 is currently offline  danpaul88
Messages: 5795
Registered: June 2004
Location: England
Karma: 0
General (5 Stars)
jonwil has samples of maps from TSR to investigate the harvester pathfinding issue, it's looking like a code regression in 4.1.

http://steamsignature.com/card/1/76561197975867233.png
Re: Map errors with 4.1 [message #486131 is a reply to message #485839] Sat, 15 February 2014 02:14 Go to previous messageGo to next message
jonwil is currently offline  jonwil
Messages: 3555
Registered: February 2003
Karma: 0
General (3 Stars)

Yeah I have tracked down the piece of code that seems to be broken and am trying to figure out whats up.

Also, the cargo plane issue is now fixed (according to Saberhawk)


Jonathan Wilson aka Jonwil
Creator and Lead Coder of the Custom scripts.dll
Renegade Engine Guru
Creator and Lead Coder of TT.DLL
Official member of Tiberian Technologies
Re: Map errors with 4.1 [message #486150 is a reply to message #485839] Sun, 16 February 2014 02:31 Go to previous message
jonwil is currently offline  jonwil
Messages: 3555
Registered: February 2003
Karma: 0
General (3 Stars)

I have a fix that fixes the pathfinding for the broken Tiberian Sun: Reborn map but I want to verify that its fixed for the Renegade map (just to be sure). Can anyone who has been having 100% reproducible pathfinding issues on a renegade map please contact me (via IRC/IM) so we can verify things?


Jonathan Wilson aka Jonwil
Creator and Lead Coder of the Custom scripts.dll
Renegade Engine Guru
Creator and Lead Coder of TT.DLL
Official member of Tiberian Technologies
Previous Topic: Fog Error?
Next Topic: Vehicle interface crash
Goto Forum:
  


Current Time: Mon Apr 22 22:06:45 MST 2024

Total time taken to generate the page: 0.01368 seconds