Renegade Public Forums
C&C: Renegade --> Dying since 2003™, resurrected in 2024!
Home » Technical Support » Win32 FDS » cant connect to server
cant connect to server [message #484197] Thu, 24 October 2013 08:13 Go to next message
robbyke is currently offline  robbyke
Messages: 348
Registered: September 2010
Location: Belgium
Karma: 0
Recruit
well first off it WORKS on my tower


okay now to the problem.

I run a lan server on my laptop to test my plugin, it used to work but all of a sudden i can no longer connect to it and i dont know why.

i also tried to connect with my tower to my laptop same problem

the server is a clean copy of my towers setup which works so it isnt in the server setup.

i tried disabling virusscanner and firewalls stil no advance, just wondering if anyone else has any ideas.


PS: i dont connect to localhost i use the external ip other lan computers would use and dirrect connect


Owner of kambot TT server

kambot.freeforums.org
Re: cant connect to server [message #484199 is a reply to message #484197] Thu, 24 October 2013 08:46 Go to previous messageGo to next message
danpaul88 is currently offline  danpaul88
Messages: 5795
Registered: June 2004
Location: England
Karma: 0
General (5 Stars)
Some (really crap) routers (looking at you BT!) don't support local-loopback properly so using the external IP could be problematic... try using its internal IP instead?


(BT did *eventually* fix this in their HH3 after years of complaints)


http://steamsignature.com/card/1/76561197975867233.png
Re: cant connect to server [message #484202 is a reply to message #484197] Thu, 24 October 2013 11:29 Go to previous messageGo to next message
ExEric3 is currently offline  ExEric3
Messages: 742
Registered: February 2005
Location: Slovakia
Karma: 0
Colonel
If you run fds in lan mode i think there is always port 4848.

Also use IP address on your NIC where is running fds.

If you disable nic and you running fds and ren on same pc then you can use 127.0.0.1:4848 at least on my side this works.
Re: cant connect to server [message #484205 is a reply to message #484197] Thu, 24 October 2013 15:37 Go to previous message
robbyke is currently offline  robbyke
Messages: 348
Registered: September 2010
Location: Belgium
Karma: 0
Recruit
the weird thing is, that it worked.
i even did a small lan game with my class and that worked, but now all of a sudden wont let me connect anymore

im stil using port 4848, just because im to lazy to change it and it wont be in use anyway as it isnt run on a real server

never tried using localhost because it didnt work one of the first times i tried it, external did

hence external works on my tower but doesnt for my laptop i could conclude its something else than my router

i believe it might not even be the server but something on windows blocking it, as the server doesnt even seem to notice the connections.

its really weird and annoying as i always coded ren on my laptop and now i cant test there slowing down the whole coding process Sad


Owner of kambot TT server

kambot.freeforums.org
Previous Topic: LuaTT
Next Topic: Need help finding Night Regulator file to install and use?
Goto Forum:
  


Current Time: Sat Apr 13 08:39:49 MST 2024

Total time taken to generate the page: 0.00788 seconds