Renegade Public Forums
C&C: Renegade --> Dying since 2003™, resurrected in 2024!
Home » Tiberian Technologies / Blackhand Studios » Tiberian Technologies Forum » Slow loading times with 4.0
Slow loading times with 4.0 [message #482147] Fri, 21 June 2013 10:01 Go to next message
(Shadow) is currently offline  (Shadow)
Messages: 2
Registered: July 2011
Karma: 0
Recruit
Hey all, ever since i've had 4.0 i've had pretty slow loading times like 40-50 seconds...

My PC is pretty fast and should blaze through it, like it did before the scripts, i know it's loading all the assets and stuff but it shouldn't take nearly 1 minute to load, those few seconds are crucial. I'm always the last one to load too it seems.

Can anyone help?
Re: Slow loading times with 4.0 [message #482151 is a reply to message #482147] Fri, 21 June 2013 10:15 Go to previous messageGo to next message
Ethenal is currently offline  Ethenal
Messages: 2532
Registered: January 2007
Location: US of A
Karma: 0
General (2 Stars)

Make an empty file in your data folder called always.dep! It may not be officially suggested to do so by TT, but it definitely makes my Renegade load quickly again!

-TLS-DJ-EYE-K wrote on Mon, 18 March 2013 07:29

Instead of showing us that u aren't more inteligent than a Toast, maybe you should start becomming good in renegade Thumbs Up

Re: Slow loading times with 4.0 [message #482178 is a reply to message #482147] Sat, 22 June 2013 03:49 Go to previous messageGo to next message
danpaul88 is currently offline  danpaul88
Messages: 5795
Registered: June 2004
Location: England
Karma: 0
General (5 Stars)
It'll also cause you FPS jitters and stalls in the middle of a map when it has to hit always.dat to load assets in because you told it not to load them during the "Loading" screen (which is what the "Loading" screen is FOR).

Mine takes about 6 seconds to load maps with 4.0, compared to about 3 without. Doesn't really make much difference for most machines...


http://steamsignature.com/card/1/76561197975867233.png

[Updated on: Sat, 22 June 2013 03:49]

Report message to a moderator

Re: Slow loading times with 4.0 [message #482180 is a reply to message #482151] Sat, 22 June 2013 05:57 Go to previous messageGo to next message
Sean is currently offline  Sean
Messages: 822
Registered: February 2009
Karma: 0
Colonel
Ethenal wrote on Fri, 21 June 2013 10:15

Make an empty file in your data folder called always.dep! It may not be officially suggested to do so by TT, but it definitely makes my Renegade load quickly again!


I'll be doing this.

Thank you.

Fuck long loading times!


Head admin at TmX (The Matrix Sniper server)

irc.thematrixserver.com
The Matrix Sniper: 188.138.84.134:4576
Re: Slow loading times with 4.0 [message #482182 is a reply to message #482178] Sat, 22 June 2013 10:29 Go to previous messageGo to next message
Ethenal is currently offline  Ethenal
Messages: 2532
Registered: January 2007
Location: US of A
Karma: 0
General (2 Stars)

danpaul88 wrote on Sat, 22 June 2013 05:49

It'll also cause you FPS jitters and stalls in the middle of a map when it has to hit always.dat to load assets in because you told it not to load them during the "Loading" screen (which is what the "Loading" screen is FOR).

Mine takes about 6 seconds to load maps with 4.0, compared to about 3 without. Doesn't really make much difference for most machines...

Like I said, it's not officially approved by TT Wink so use at your own risk! However, for me personally it literally takes my Renegade sometimes 30+ seconds to load a single map, while with the empty always.dep it loads in around 3 seconds.


-TLS-DJ-EYE-K wrote on Mon, 18 March 2013 07:29

Instead of showing us that u aren't more inteligent than a Toast, maybe you should start becomming good in renegade Thumbs Up

Re: Slow loading times with 4.0 [message #482188 is a reply to message #482182] Sat, 22 June 2013 12:40 Go to previous messageGo to next message
Lazy5686 is currently offline  Lazy5686
Messages: 254
Registered: November 2007
Karma: 0
Recruit
Ethenal wrote on Sat, 22 June 2013 10:29

danpaul88 wrote on Sat, 22 June 2013 05:49

It'll also cause you FPS jitters and stalls in the middle of a map when it has to hit always.dat to load assets in because you told it not to load them during the "Loading" screen (which is what the "Loading" screen is FOR).

Mine takes about 6 seconds to load maps with 4.0, compared to about 3 without. Doesn't really make much difference for most machines...

Like I said, it's not officially approved by TT Wink so use at your own risk! However, for me personally it literally takes my Renegade sometimes 30+ seconds to load a single map, while with the empty always.dep it loads in around 3 seconds.

I haven't noticed any FPS jitters at all. From what I understand 3.4 did essentially the same thing.


The Scruffy, AngryCanadian with Vuvuzelas
-Jelly Games admin
http://i.imgur.com/7RiVG.jpg
Re: Slow loading times with 4.0 [message #482194 is a reply to message #482182] Sat, 22 June 2013 15:34 Go to previous messageGo to next message
Sean is currently offline  Sean
Messages: 822
Registered: February 2009
Karma: 0
Colonel
Ethenal wrote on Sat, 22 June 2013 10:29

danpaul88 wrote on Sat, 22 June 2013 05:49

It'll also cause you FPS jitters and stalls in the middle of a map when it has to hit always.dat to load assets in because you told it not to load them during the "Loading" screen (which is what the "Loading" screen is FOR).

Mine takes about 6 seconds to load maps with 4.0, compared to about 3 without. Doesn't really make much difference for most machines...

Like I said, it's not officially approved by TT Wink so use at your own risk! However, for me personally it literally takes my Renegade sometimes 30+ seconds to load a single map, while with the empty always.dep it loads in around 3 seconds.


This had really made such a huge difference. I'm actually loading my games fast again.

Thank you Ethenal. Smile


Head admin at TmX (The Matrix Sniper server)

irc.thematrixserver.com
The Matrix Sniper: 188.138.84.134:4576
Re: Slow loading times with 4.0 [message #482256 is a reply to message #482147] Mon, 24 June 2013 09:08 Go to previous messageGo to next message
EvilWhiteDragon is currently offline  EvilWhiteDragon
Messages: 3751
Registered: October 2005
Location: The Netherlands
Karma: 0
General (3 Stars)

The reason that it is unofficial is because it may create FPS lag later on in the game, as it loads the data it needs at runtime instead of during loading.

http://www.blackintel.org/usr/evilwhitedragon/pointfix.gif
BlackIntel admin/founder/PR dude (not a coder)
Please visit http://www.blackintel.org/

V, V for Vendetta

People should not be afraid of their governments.
Governments should be afraid of their people.
Re: Slow loading times with 4.0 [message #482262 is a reply to message #482256] Mon, 24 June 2013 11:11 Go to previous messageGo to next message
Ethenal is currently offline  Ethenal
Messages: 2532
Registered: January 2007
Location: US of A
Karma: 0
General (2 Stars)

EvilWhiteDragon wrote on Mon, 24 June 2013 11:08

The reason that it is unofficial is because it may create FPS lag later on in the game, as it loads the data it needs at runtime instead of during loading.

I expected as such, as that only makes sense - but for the most part, I have yet to notice much of a penalty at all.


-TLS-DJ-EYE-K wrote on Mon, 18 March 2013 07:29

Instead of showing us that u aren't more inteligent than a Toast, maybe you should start becomming good in renegade Thumbs Up

Re: Slow loading times with 4.0 [message #482268 is a reply to message #482182] Mon, 24 June 2013 15:44 Go to previous messageGo to next message
Starbuzz is currently offline  Starbuzz
Messages: 2491
Registered: May 2007
Karma: 2
General (2 Stars)
Ethenal wrote on Sat, 22 June 2013 13:29

danpaul88 wrote on Sat, 22 June 2013 05:49

It'll also cause you FPS jitters and stalls in the middle of a map when it has to hit always.dat to load assets in because you told it not to load them during the "Loading" screen (which is what the "Loading" screen is FOR).

Mine takes about 6 seconds to load maps with 4.0, compared to about 3 without. Doesn't really make much difference for most machines...

Like I said, it's not officially approved by TT Wink so use at your own risk! However, for me personally it literally takes my Renegade sometimes 30+ seconds to load a single map, while with the empty always.dep it loads in around 3 seconds.


LOL Ethenal, at first I actually thought you were making a troll joke!


buzzsigfinal
Re: Slow loading times with 4.0 [message #482290 is a reply to message #482262] Tue, 25 June 2013 01:50 Go to previous message
EvilWhiteDragon is currently offline  EvilWhiteDragon
Messages: 3751
Registered: October 2005
Location: The Netherlands
Karma: 0
General (3 Stars)

Ethenal wrote on Mon, 24 June 2013 20:11

EvilWhiteDragon wrote on Mon, 24 June 2013 11:08

The reason that it is unofficial is because it may create FPS lag later on in the game, as it loads the data it needs at runtime instead of during loading.

I expected as such, as that only makes sense - but for the most part, I have yet to notice much of a penalty at all.

Just next time, when you post that "workaround", also mention why it is unofficial and we advise against it Wink Possibly saves some help-requests when people experience framedrops.


http://www.blackintel.org/usr/evilwhitedragon/pointfix.gif
BlackIntel admin/founder/PR dude (not a coder)
Please visit http://www.blackintel.org/

V, V for Vendetta

People should not be afraid of their governments.
Governments should be afraid of their people.
Previous Topic: mixcheck downloading/extracting empty maps
Next Topic: Server crash dump
Goto Forum:
  


Current Time: Tue Jun 18 01:50:51 MST 2024

Total time taken to generate the page: 0.01536 seconds