Renegade Public Forums
C&C: Renegade --> Dying since 2003™, resurrected in 2024!
Home » Tiberian Technologies / Blackhand Studios » Tiberian Technologies Forum » Crash dump (Hoping to play renegade after a couple year break :D)
Crash dump [message #482002] Fri, 14 June 2013 21:38 Go to next message
diox8tony is currently offline  diox8tony
Messages: 15
Registered: November 2005
Location: mt usa
Karma: 0
Recruit
0) I am running Windows 7

1) i installed renegade from a version which is working perfectly fine for my friend(watching him play online now Sad )

2) i installed the latest TT 4.0 scripts. I assume this is the client version RC3 since the latest in archive is RC2.

3) i start the game and try to open a multiplayer practice. Halfway thru loading the level i get a windows message "renegade has encountered an internal error and is unable to continue normally", the program is forced to close. this error appears everytime a level is tried to load.

[Updated on: Sun, 16 June 2013 12:03] by Moderator

Report message to a moderator

Re: Crash dump [message #482006 is a reply to message #482002] Fri, 14 June 2013 22:56 Go to previous messageGo to next message
diox8tony is currently offline  diox8tony
Messages: 15
Registered: November 2005
Location: mt usa
Karma: 0
Recruit
update,,,I downloaded Renlist 1.0.5 and installed/ran it.

Set my name in setting in WOL and GSA.

When i double click a server to join, i get the "tt.dll requires windows XP/2003/Vista/2008/7 to Run" error
Re: Crash dump [message #482009 is a reply to message #482006] Fri, 14 June 2013 23:32 Go to previous messageGo to next message
saberhawk
Messages: 1068
Registered: January 2006
Location: ::1
Karma: 0
General (1 Star)
diox8tony wrote on Fri, 14 June 2013 22:56

update,,,I downloaded Renlist 1.0.5 and installed/ran it.

Set my name in setting in WOL and GSA.

When i double click a server to join, i get the "tt.dll requires windows XP/2003/Vista/2008/7 to Run" error


scripts 4.0 doesn't require any compatibility settings to run, and setting some might actually cause problems. You should remove any compatibility mode you might have set by right clicking on game2.exe, going to properties, and unchecking everything set in the compatibility tab.
Re: Crash dump [message #482010 is a reply to message #482002] Fri, 14 June 2013 23:45 Go to previous messageGo to next message
diox8tony is currently offline  diox8tony
Messages: 15
Registered: November 2005
Location: mt usa
Karma: 0
Recruit
all .exe i can find for renegade have nothing in the complatibilty tab,,,also I am giving the .exe's admin privileges. but TY
Re: Crash dump [message #482011 is a reply to message #482010] Sat, 15 June 2013 00:05 Go to previous messageGo to next message
saberhawk
Messages: 1068
Registered: January 2006
Location: ::1
Karma: 0
General (1 Star)
diox8tony wrote on Fri, 14 June 2013 23:45

all .exe i can find for renegade have nothing in the complatibilty tab,,,also I am giving the .exe's admin privileges. but TY


It doesn't even need those. All the admin related issues were fixed pretty early on in the development of 4.0. The "tt.dll requires Windows XP/2003/Vista/2008/7 to Run" error can only appear with incorrect compatibility settings; they might be set on RenList.
Re: Crash dump [message #482013 is a reply to message #482011] Sat, 15 June 2013 01:42 Go to previous messageGo to next message
diox8tony is currently offline  diox8tony
Messages: 15
Registered: November 2005
Location: mt usa
Karma: 0
Recruit
no compatibility modes enabled for renList.exe,,,game.exe,,,game2.exe,,,or Renegade.exe
Re: Crash dump [message #482015 is a reply to message #482002] Sat, 15 June 2013 03:22 Go to previous messageGo to next message
iRANian is currently offline  iRANian
Messages: 4299
Registered: April 2011
Karma: 0
General (4 Stars)
The crashdump shows the game crashing in tt.dll code.

Long time and well respected Renegade community member, programmer, modder and tester.

Scripts 4.0 private beta tester since May 2011.

My Renegade server plugins releases
Re: Crash dump [message #482017 is a reply to message #482002] Sat, 15 June 2013 03:45 Go to previous messageGo to next message
iRANian is currently offline  iRANian
Messages: 4299
Registered: April 2011
Karma: 0
General (4 Stars)
His issues were resolved after re-installing, installing 1.037 and then 4.0.

He didn't install 1.037 before so the game gave him a version mismatch while playing with 4.0. After re-installing he had to immediately install 4.0 because the game patched to 1.037 crashed for him, installing 4.0 fixed that. He's running windows 7 64-bit.


Long time and well respected Renegade community member, programmer, modder and tester.

Scripts 4.0 private beta tester since May 2011.

My Renegade server plugins releases
Re: Crash dump [message #482019 is a reply to message #482015] Sat, 15 June 2013 03:53 Go to previous messageGo to next message
saberhawk
Messages: 1068
Registered: January 2006
Location: ::1
Karma: 0
General (1 Star)
iRANian wrote on Sat, 15 June 2013 03:22

The crashdump shows the game crashing in tt.dll code.


The crashdump, sure; he mentioned "tt.dll requires Windows XP/2003/Vista/2008/7 to Run" however which can only be triggered on 7 if using compatibility settings.
Re: Crash dump [message #482020 is a reply to message #482002] Sat, 15 June 2013 05:09 Go to previous message
diox8tony is currently offline  diox8tony
Messages: 15
Registered: November 2005
Location: mt usa
Karma: 0
Recruit
Like Iran said,,,my issue was resolved by:
1) installing renegade
2) installing path 1.037
3) installing TT 4.0 scripts
4) installing renlist
5) point renlist to load game.exe
6) join server via renlist.

TY for your help Iran + Saber
Previous Topic: Bug?
Next Topic: 3 client crashes in the same match
Goto Forum:
  


Current Time: Fri May 17 23:17:24 MST 2024

Total time taken to generate the page: 0.00767 seconds