Renegade Public Forums
C&C: Renegade --> Dying since 2003™, resurrected in 2024!
Home » Technical Support » Win32 FDS » LuaTT
LuaTT [message #480211] Sat, 30 March 2013 14:27 Go to next message
Comp_uter15776 is currently offline  Comp_uter15776
Messages: 21
Registered: November 2010
Karma: 0
Recruit
Hey all,

Long time no see ^.^ I've decided to go back to Ren to just do some coding and playing around with the FDS, I've missed its customizability so much. However, upon setting up the server, I noticed that TT has progressed to RC2. I then noticed that LuaTT's last update was for Beta 5. Does anyone have an idea if a LuaPlugin will be created/updated for this version of TT server?

Sla.ro, if you're reading, please update it! There is a void that was filled when you initially made it - it'd be a pleasure to be able to use Lua again.

Here's what my FDS is outputting so far:

http://prntscr.com/yhrz4

Unfortunately it's been so long I cannot remember whether LuaTT displays a load message or not. Anything to shed light on the whole matter would be greatly appreciated!


Regards, Comp_uter15776

P.S. Sorry if I posted in the wrong section... I figured this would be best but who knows ^.^
Re: LuaTT [message #480212 is a reply to message #480211] Sat, 30 March 2013 14:52 Go to previous messageGo to next message
danpaul88 is currently offline  danpaul88
Messages: 5795
Registered: June 2004
Location: England
Karma: 0
General (5 Stars)
TT is past RC2, it's actually had a final release of 4.0 now. I don't know if the LUA thing will ever be updated though, or if the existing one might work...

http://steamsignature.com/card/1/76561197975867233.png
Re: LuaTT [message #480213 is a reply to message #480212] Sat, 30 March 2013 15:15 Go to previous messageGo to next message
Comp_uter15776 is currently offline  Comp_uter15776
Messages: 21
Registered: November 2010
Karma: 0
Recruit
Well, I've tried the existing LuaPlugin (LuaTT ver 1.2) to no avail :/

In fact, I can't get any Lua plugin to work with any SSGM/server... the old versions say "can't find file/dir" *some random characters* "LuaPlugins" *more random characters*, and the new versions don't appear at all ;_;

I do hope at least someone ports the code! someone!


*random character example* http://prntscr.com/yi16i

[Updated on: Sat, 30 March 2013 15:18]

Report message to a moderator

Re: LuaTT [message #480215 is a reply to message #480213] Sun, 31 March 2013 01:42 Go to previous messageGo to next message
sla.ro(master) is currently offline  sla.ro(master)
Messages: 610
Registered: September 2010
Location: Romania
Karma: 0
Colonel
the current LuaTT should work fine with RC2, but i uploaded the RC2 build of LuaTT (source and binary).

You can see the functions on our wiki here

If you have suggestions, contact me with a pm here at forums or on our irc.

Source link.
Binary Link (is what you need for FDS)

Thanks.


Creator of Mutant Co-Op
Developer of LuaTT
Re: LuaTT [message #480217 is a reply to message #480215] Sun, 31 March 2013 01:47 Go to previous messageGo to next message
Comp_uter15776 is currently offline  Comp_uter15776
Messages: 21
Registered: November 2010
Karma: 0
Recruit
Thanks a bunch sla.ro.

However, it should work fine with TT servers, if what you say is true, but I don't have any working, "clean" TT servers. All I get is "set working folder and try again" if I try put a new server up... I had a couple of older TT servers which I think may have been from the beta 3 days, but they don't even register the dll, of any type (LuaPlugin/LuaTT).

If anyone knows how to rectify that "set working folder" issue, I'd be extremely thankful!

Regards, Comp_uter15776

Edit: This is what I've been getting for any TT server: http://prntscr.com/ykeu0

[Updated on: Sun, 31 March 2013 04:24]

Report message to a moderator

Re: LuaTT [message #480223 is a reply to message #480217] Sun, 31 March 2013 11:31 Go to previous messageGo to next message
sla.ro(master) is currently offline  sla.ro(master)
Messages: 610
Registered: September 2010
Location: Romania
Karma: 0
Colonel
I'm not sure, but probably something is missing that TT needs, try ask some TT developer.

Creator of Mutant Co-Op
Developer of LuaTT
Re: LuaTT [message #480224 is a reply to message #480211] Sun, 31 March 2013 11:58 Go to previous messageGo to next message
Dev* is currently offline  Dev*
Messages: 27
Registered: March 2012
Location: The Capital Wasteland
Karma: 0
Recruit
Make sure always.dat is in the data folder.
This does not come with a Tiberian Tech Server. You must overwrite an FDS with the TT Server.

[Updated on: Sun, 31 March 2013 12:00]

Report message to a moderator

Re: LuaTT [message #480225 is a reply to message #480224] Sun, 31 March 2013 12:31 Go to previous messageGo to next message
Comp_uter15776 is currently offline  Comp_uter15776
Messages: 21
Registered: November 2010
Karma: 0
Recruit
Ah excellent!

Now it's back to sq. 1 I'm afraid :/

This is what I'm seeing with LuaTT RC2, TT serv RC2 patched ontop of a clean RenFDS install. Server.ini settings were only modified to include nickname, password, serial.

Anyone have any idea whether this photo is displaying the correct info or not? http://prntscr.com/ymbdx
Re: LuaTT [message #480227 is a reply to message #480211] Sun, 31 March 2013 12:50 Go to previous messageGo to next message
Dev* is currently offline  Dev*
Messages: 27
Registered: March 2012
Location: The Capital Wasteland
Karma: 0
Recruit
If the problem is that LuaTT wont run. Then you forgot to add it under plugins in the SSGM.ini or w/e the file is called.

Example

[Plugins]
00=BanSystem.dll
01=Mute.dll

Above is probably what you have.
Make it like this.
[Plugins]
00=BanSystem.dll
01=Mute.dll
02=LuaTT.dll

Make sure LuaTT.dll is in the root of your server folder.

[Updated on: Sun, 31 March 2013 12:53]

Report message to a moderator

Re: LuaTT [message #480228 is a reply to message #480227] Sun, 31 March 2013 12:51 Go to previous messageGo to next message
Comp_uter15776 is currently offline  Comp_uter15776
Messages: 21
Registered: November 2010
Karma: 0
Recruit
Oops, forgot to mention: http://prntscr.com/ymfa6

I changed it to that too. Still a no-show? :s
Re: LuaTT [message #480229 is a reply to message #480211] Sun, 31 March 2013 12:54 Go to previous messageGo to next message
Dev* is currently offline  Dev*
Messages: 27
Registered: March 2012
Location: The Capital Wasteland
Karma: 0
Recruit
You put it under [ListofPresets]. It is supposed to go under [Plugins].

[Updated on: Sun, 31 March 2013 12:54]

Report message to a moderator

Re: LuaTT [message #480230 is a reply to message #480229] Sun, 31 March 2013 12:56 Go to previous messageGo to next message
Comp_uter15776 is currently offline  Comp_uter15776
Messages: 21
Registered: November 2010
Karma: 0
Recruit
AWH HELL NO

Thanks man, case solved.

Double Edit:

Found solution to random letter crap. I needed to create the folder too.


Thanks again to everyone! ^.^

[Updated on: Sun, 31 March 2013 12:59]

Report message to a moderator

Re: LuaTT [message #480231 is a reply to message #480211] Sun, 31 March 2013 12:59 Go to previous messageGo to next message
Dev* is currently offline  Dev*
Messages: 27
Registered: March 2012
Location: The Capital Wasteland
Karma: 0
Recruit
Yeah, Lua files go into the LuaPlugins folder that should be located at the root of the server directory.

If you have any Lua Requests you can find me @ slairc.
Re: LuaTT [message #480232 is a reply to message #480231] Sun, 31 March 2013 13:04 Go to previous message
Comp_uter15776 is currently offline  Comp_uter15776
Messages: 21
Registered: November 2010
Karma: 0
Recruit
Ah thanks, I'll definitely get in touch should I need more help! Smile

Regards, Comp_uter15776
Previous Topic: Server Hosting needed
Next Topic: cant connect to server
Goto Forum:
  


Current Time: Thu Apr 18 04:40:43 MST 2024

Total time taken to generate the page: 0.01055 seconds