Renegade Public Forums
C&C: Renegade --> Dying since 2003™, resurrected in 2024!
Home » Renegade Discussions » Mod Forum » Help With DirectX
Help With DirectX [message #479388] Thu, 21 February 2013 11:34 Go to next message
mario64guy is currently offline  mario64guy
Messages: 1
Registered: May 2011
Location: ctf_2fort
Karma: 0
Recruit
Recently, I got a new computer, and felt like playing Ren on it with all the graphics maxed out. The only trouble is that whenever I start the game, it says "You need to update your version of DirectX in order to use this copy of scripts.dll." I have 11, so is Ren so old it isn't compatible with the newest version, or is it an issue on my end? Assistance would be appreciated.

Edit: Fixed. Just had to reinstall scripts.

[Updated on: Thu, 21 February 2013 11:41]

Report message to a moderator

Re: Help With DirectX [message #479398 is a reply to message #479388] Thu, 21 February 2013 14:40 Go to previous message
saberhawk
Messages: 1068
Registered: January 2006
Location: ::1
Karma: 0
General (1 Star)
mario64guy wrote on Thu, 21 February 2013 10:34

Recently, I got a new computer, and felt like playing Ren on it with all the graphics maxed out. The only trouble is that whenever I start the game, it says "You need to update your version of DirectX in order to use this copy of scripts.dll." I have 11, so is Ren so old it isn't compatible with the newest version, or is it an issue on my end? Assistance would be appreciated.

Edit: Fixed. Just had to reinstall scripts.



Right, so Microsoft decided at some point to release additional updates for a Direct3D9 library called D3DX. They kept doing this for some time (the last being released on June 2010, roughly a year Direct3D11 was released). They also haven't been including said updates with Windows.

Games are supposed to install whatever version they need, and the scripts 4.0 installer does this. However, if you reinstall Windows (or change computers) and try running Renegade without reinstalling scripts 4.0 *or* running the DirectX End-User Runtime Web Installer, you will get that error message because your version of DirectX *is* out of date and you do need to update in order to play.
Previous Topic: Please Unban.
Next Topic: Looking for someone who can make me a test map
Goto Forum:
  


Current Time: Sat Apr 13 22:29:20 MST 2024

Total time taken to generate the page: 0.00560 seconds