Renegade Public Forums
C&C: Renegade --> Dying since 2003™, resurrected in 2024!
Home » Tiberian Technologies / Blackhand Studios » Tiberian Technologies Forum » Bugs in 4.0
Bugs in 4.0 [message #477971] Tue, 11 December 2012 17:46 Go to next message
Poskov
Messages: 235
Registered: March 2008
Location: Western Oceania
Karma: 0
Recruit
Here are the bugs that I found:

>Weapon MuzzleFlashPhysDefID Lifetime does not work anymore
>The ambient sound announcements in MP Practice are too frequent
>Explosion Lifetime does not work anymore
>In SP, the bots have their 'friendly fire' and 'take damage' voices swapped
>Decal limit is still the same
>Number of simultaneous sounds allowed is still the same

Also, can the View Distance and LOD Budget be changed in 4.0?

[Updated on: Tue, 11 December 2012 18:27]

Report message to a moderator

Re: Bugs in 4.0 [message #477973 is a reply to message #477971] Wed, 12 December 2012 05:55 Go to previous messageGo to next message
danpaul88 is currently offline  danpaul88
Messages: 5795
Registered: June 2004
Location: England
Karma: 0
General (5 Stars)
can you elaborate on the two "lifetime doesnt work" bugs you mention? if they had no lifetime they would never vanish, i think people might have noticed that...

http://steamsignature.com/card/1/76561197975867233.png
Re: Bugs in 4.0 [message #478916 is a reply to message #477971] Fri, 25 January 2013 13:18 Go to previous messageGo to next message
Poskov
Messages: 235
Registered: March 2008
Location: Western Oceania
Karma: 0
Recruit
MuzzleFlashPhysDefID & Explosion lifetimes are stuck at 2 seconds

Non-animated explosion models will last too long (2 seconds) (like RP2's nitro freezer ice)

The same goes for muzzleflashes of MuzzleFlashPhysDefID

[Updated on: Fri, 25 January 2013 13:19]

Report message to a moderator

Re: Bugs in 4.0 [message #478918 is a reply to message #477971] Fri, 25 January 2013 14:58 Go to previous messageGo to next message
EvilWhiteDragon is currently offline  EvilWhiteDragon
Messages: 3751
Registered: October 2005
Location: The Netherlands
Karma: 0
General (3 Stars)

Have you tried with RC2?

http://www.blackintel.org/usr/evilwhitedragon/pointfix.gif
BlackIntel admin/founder/PR dude (not a coder)
Please visit http://www.blackintel.org/

V, V for Vendetta

People should not be afraid of their governments.
Governments should be afraid of their people.
Re: Bugs in 4.0 [message #479320 is a reply to message #477971] Sun, 17 February 2013 00:35 Go to previous messageGo to next message
Poskov
Messages: 235
Registered: March 2008
Location: Western Oceania
Karma: 0
Recruit
Yes, the bugs are still there in RC2

[Updated on: Sun, 17 February 2013 00:37]

Report message to a moderator

Re: Bugs in 4.0 [message #479326 is a reply to message #477971] Sun, 17 February 2013 08:49 Go to previous messageGo to next message
Gen_Blacky is currently offline  Gen_Blacky
Messages: 3250
Registered: September 2006
Karma: 1
General (3 Stars)
MuzzleFlashPhysDefID has been broken since 4.0 release I believe.

Doesn't work in Lan or Multilayer.

The muzzle flash lasts for about 2 seconds no matter what its set to.

Only a problem if set in LE.

Using RC3 Beta on client. RC2 Server.




From what I have seen Explosion Lifetime still works but I have not tested.


http://s18.postimage.org/jc6qbn4k9/bricks3.png

[Updated on: Sun, 17 February 2013 08:50]

Report message to a moderator

Re: Bugs in 4.0 [message #479327 is a reply to message #477971] Sun, 17 February 2013 08:52 Go to previous messageGo to next message
jonwil is currently offline  jonwil
Messages: 3555
Registered: February 2003
Karma: 0
General (3 Stars)

Can someone get me a test setup (mix file or whatever) that I can use to see this muzzle flash issue in action?


Jonathan Wilson aka Jonwil
Creator and Lead Coder of the Custom scripts.dll
Renegade Engine Guru
Creator and Lead Coder of TT.DLL
Official member of Tiberian Technologies
Re: Bugs in 4.0 [message #479328 is a reply to message #477971] Sun, 17 February 2013 09:21 Go to previous messageGo to next message
Gen_Blacky is currently offline  Gen_Blacky
Messages: 3250
Registered: September 2006
Karma: 1
General (3 Stars)
The weapon spawns next to the gdi wf.

http://s18.postimage.org/jc6qbn4k9/bricks3.png

[Updated on: Mon, 18 February 2013 08:10]

Report message to a moderator

Re: Bugs in 4.0 [message #479342 is a reply to message #477971] Sun, 17 February 2013 17:43 Go to previous messageGo to next message
jonwil is currently offline  jonwil
Messages: 3555
Registered: February 2003
Karma: 0
General (3 Stars)

I cant find anything that looks like a weapon powerup or a gun anywhere near the GDI weapons factory on that test map.


Jonathan Wilson aka Jonwil
Creator and Lead Coder of the Custom scripts.dll
Renegade Engine Guru
Creator and Lead Coder of TT.DLL
Official member of Tiberian Technologies
Re: Bugs in 4.0 [message #479343 is a reply to message #477971] Sun, 17 February 2013 20:21 Go to previous messageGo to next message
Gen_Blacky is currently offline  Gen_Blacky
Messages: 3250
Registered: September 2006
Karma: 1
General (3 Stars)
Its missing textures.
  • Attachment: 111.jpg
    (Size: 479.96KB, Downloaded 130 times)


http://s18.postimage.org/jc6qbn4k9/bricks3.png

[Updated on: Sun, 17 February 2013 20:22]

Report message to a moderator

Re: Bugs in 4.0 [message #479344 is a reply to message #477971] Sun, 17 February 2013 20:51 Go to previous messageGo to next message
jonwil is currently offline  jonwil
Messages: 3555
Registered: February 2003
Karma: 0
General (3 Stars)

I looked in that exact spot and I cant see the weapon powerup at all.


Jonathan Wilson aka Jonwil
Creator and Lead Coder of the Custom scripts.dll
Renegade Engine Guru
Creator and Lead Coder of TT.DLL
Official member of Tiberian Technologies
Re: Bugs in 4.0 [message #479346 is a reply to message #477971] Mon, 18 February 2013 08:09 Go to previous messageGo to next message
Gen_Blacky is currently offline  Gen_Blacky
Messages: 3250
Registered: September 2006
Karma: 1
General (3 Stars)
My bad missing powerup model along with textures.



http://s18.postimage.org/jc6qbn4k9/bricks3.png

[Updated on: Mon, 18 February 2013 08:18]

Report message to a moderator

Re: Bugs in 4.0 [message #479405 is a reply to message #477971] Thu, 21 February 2013 18:32 Go to previous messageGo to next message
Gen_Blacky is currently offline  Gen_Blacky
Messages: 3250
Registered: September 2006
Karma: 1
General (3 Stars)
Did you find the problem with the emitter lifetime?

http://s18.postimage.org/jc6qbn4k9/bricks3.png
Re: Bugs in 4.0 [message #479588 is a reply to message #479405] Wed, 27 February 2013 16:53 Go to previous message
Jerad2142 is currently offline  Jerad2142
Messages: 3805
Registered: July 2006
Location: USA
Karma: 6
General (3 Stars)
Rp2 was buggy as fuck, ECW is just about ready for release and after that is confirmed stable we will start to port to 4.0. Hopefully that'll go smoothly (I doubt it but we shall see, it'd be amazing if it was perfectly stable under 4.0 but I don't expect it).

Previous Topic: Crashdumps
Next Topic: Tiberian Technologies releases TT scripts 4.0 final!
Goto Forum:
  


Current Time: Tue Jun 18 01:49:17 MST 2024

Total time taken to generate the page: 0.00920 seconds