Renegade Public Forums
C&C: Renegade --> Dying since 2003™, resurrected in 2024!
Home » Tiberian Technologies / Blackhand Studios » Tiberian Technologies Forum » Messages missing since 4.0
Messages missing since 4.0 [message #464304] Mon, 12 March 2012 10:33 Go to next message
T0RN is currently offline  T0RN
Messages: 293
Registered: January 2006
Location: Lunatic HQ
Karma: 0
Recruit
No more end game message
[GENERAL] Current game on map C&C_Volcano.mix has ended. Game was won by GDI by Pedestal Beacon.

No more beacon message
[BEACON] DJFETISH deployed a Ion Cannon Beacon
[BEACON] Ion Cannon Strike initiated
[BEACON] Ion Cannon Beacon has detonated

No more building kill message like this
Host: Hand of Nod destroyed by DJFETISH.

Also, if I turn extra kill messages off, like T0RN killed their dumb self.
I don't get even the old default one of T0RN killed their self, or T0RN didn't last too long in the tiberium.

[Updated on: Mon, 12 March 2012 10:40]

Report message to a moderator

Re: Messages missing since 4.0 [message #464327 is a reply to message #464304] Mon, 12 March 2012 16:17 Go to previous messageGo to next message
Xpert is currently offline  Xpert
Messages: 1588
Registered: December 2005
Location: New York City
Karma: 0
General (1 Star)
You do realize all the stuff you're reporting is a problem on the bot's end? Those gamelog messages exist.


Example from my bot:

<CloudyServ2> Current game on map C&C_Islands.mix has ended. Game was won by Nod by High score when time limit expired.

[19:13:30] <CloudyServ> [Enter] Sketchz entered a Nod Mobile Artillery (Technician).
[19:13:30] <CloudyServ> [GDI] WNxAtomic has purchased a Character - Hotwire.
[19:13:31] <CloudyServ> [GDI] WNxAtomic has purchased a Character - Hotwire.
[19:13:31] <CloudyServ> [Kill] Schossi killed BuddeApun (Hotwire/Automatic Pistol VS. Shotgun Trooper/Shotgun).
[19:13:31] <CloudyServ> [Exit] Sketchz exited a Nod Mobile Artillery (Technician).
[19:13:32] <CloudyServ> [Building] cadete44 destroyed the Hand of Nod (Engineer/Remote C4).
[19:13:32] <CloudyServ> Host: [CS] cadete44 has received a recommendation medal for destroying the Hand of Nod.
[19:13:32] <CloudyServ> [Enter] Sketchz entered a Nod Mobile Artillery (Technician).
[19:13:34] <CloudyServ> [Exit] Sketchz exited a Nod Mobile Artillery (Technician).
[19:13:35] <CloudyServ> [GDI] WNxAtomic has purchased a Vehicle - GDI Medium Tank.


http://i32.photobucket.com/albums/d42/XpertMaverick/xpertyankee.jpg

Creator of NetGuard, an IRC network regulator.
Developer of the CloudyServ 0.982-X project.
Developer of the CloudyServ Ren-X bot.

Part time streamer - https://twitch.tv/gg_wonder
Re: Messages missing since 4.0 [message #464331 is a reply to message #464327] Mon, 12 March 2012 18:16 Go to previous messageGo to next message
Ethenal is currently offline  Ethenal
Messages: 2532
Registered: January 2007
Location: US of A
Karma: 0
General (2 Stars)

Xpert wrote on Mon, 12 March 2012 18:17

You do realize all the stuff you're reporting is a problem on the bot's end? Those gamelog messages exist.


That was exactly my thoughts. Seems BR misses quite a few gamelog events now (or at least something weird is going on with the gamelog reading).


-TLS-DJ-EYE-K wrote on Mon, 18 March 2013 07:29

Instead of showing us that u aren't more inteligent than a Toast, maybe you should start becomming good in renegade Thumbs Up

Re: Messages missing since 4.0 [message #464342 is a reply to message #464304] Tue, 13 March 2012 01:23 Go to previous messageGo to next message
T0RN is currently offline  T0RN
Messages: 293
Registered: January 2006
Location: Lunatic HQ
Karma: 0
Recruit
Whatever is causing it, it's bothering me.
There's more but I can't think of them right now. Just woke up lol
Re: Messages missing since 4.0 [message #464366 is a reply to message #464304] Tue, 13 March 2012 12:02 Go to previous messageGo to next message
danpaul88 is currently offline  danpaul88
Messages: 5795
Registered: June 2004
Location: England
Karma: 0
General (5 Stars)
All BRenBot does is forward the logs from the TCP socket to the relevant parsing functions that already existed. If the new messages no longer match the format of the old ones I will need examples of the new messages to update the parsing code.

However, I was informed by jonwil that the new messages are *supposed* to be identical the originals... so if they are not that could be considered an SSGM 4.0 bug.


http://steamsignature.com/card/1/76561197975867233.png

[Updated on: Tue, 13 March 2012 12:02]

Report message to a moderator

Re: Messages missing since 4.0 [message #464367 is a reply to message #464304] Tue, 13 March 2012 12:23 Go to previous messageGo to next message
danpaul88 is currently offline  danpaul88
Messages: 5795
Registered: June 2004
Location: England
Karma: 0
General (5 Stars)
For reference, BRenBot supports the following Gamelog messages;

Quote:

sub parse_line
{
my $line = shift;

if ( $line =~ m/\[(.+?)\] CRATE/ && $startup != 1 )
{
crate($line);
}
elsif ( $line =~ m/\[(.+?)\] CREATED/ )
{
created($line);
}
elsif ( $line =~ m/\[(.+?)\] DESTROYED/ )
{
destroyed($line);
}
elsif ( $line =~ m/\[(.+?)\] POS/ && $startup != 1 )
{
position($line);
}
elsif ( $line =~ m/\[(.+?)\] ENTER/ )
{
enter($line);
}
elsif ( $line =~ m/\[(.+?)\] EXIT/ )
{
exit_vehicle($line);
}
elsif ( $line =~ m/\[(.+?)\] DAMAGED/ && $startup != 1 )
{
damaged($line);
}
elsif ( $line =~ m/\[(.+?)\] KILLED/ )
{
killed($line);
}
elsif ( $line =~ m/\[(.+?)\] WIN/ )
{
clear();
}
elsif ( $line =~ m/\[(.+?)\] CONFIG/ && $startup != 1)
{
clear();
}


# Look for any plugins whose regex hooks match this line
my @plugins = plugin::get_plugin_gamelog_regexes();

my %args;
$args{line} = $line;
$args{startup} = $startup;

foreach (@plugins)
{
my $plugin = $_;
my %regexes = %{$plugin::plugin_gamelog_regexes{$plugin}};
my $alias = "plugin_" . $plugin;

while (my ($regex, $event) = each %regexes)
{
if ( $line =~ m/$regex/i )
{ $main::poe_kernel->post($alias => $event => \%args); }
}
}
}



http://steamsignature.com/card/1/76561197975867233.png

[Updated on: Tue, 13 March 2012 12:24]

Report message to a moderator

Re: Messages missing since 4.0 [message #465019 is a reply to message #464304] Wed, 28 March 2012 02:20 Go to previous messageGo to next message
jonwil is currently offline  jonwil
Messages: 3556
Registered: February 2003
Karma: 0
General (3 Stars)

Can someone get me details of exactly which messages are missing (i.e. what the messages looked like in the old SSGM, not what a bot may have done with them)?


Jonathan Wilson aka Jonwil
Creator and Lead Coder of the Custom scripts.dll
Renegade Engine Guru
Creator and Lead Coder of TT.DLL
Official member of Tiberian Technologies
Re: Messages missing since 4.0 [message #465022 is a reply to message #465019] Wed, 28 March 2012 02:52 Go to previous messageGo to next message
sla.ro(master) is currently offline  sla.ro(master)
Messages: 610
Registered: September 2010
Location: Romania
Karma: 0
Colonel
i think can be done by plugin, not sure, on my bot i used ssgm 2.02 as example to port on Lua.

for game end: [12:13:38] <&SlaServer> [GameOver] GDI won by Pedestal Beacon - Map last 4 days 10:25:39 hours

for beacon: [12:13:07] <&SlaServer> [Beacon] Furieux_de_canard deployed a beacon.

Beacon and General headers are missing, personally i don't need them because all in my bot isn't ssgm, but peoples who uses BrenBot they need to know when someone placed a beacon Wink


Creator of Mutant Co-Op
Developer of LuaTT
Re: Messages missing since 4.0 [message #465026 is a reply to message #464304] Wed, 28 March 2012 04:58 Go to previous messageGo to next message
Ani is currently offline  Ani
Messages: 399
Registered: February 2012
Location: New York City
Karma: 0
Commander
Beacons are definitely missing from BR's output. Thumbs Up
Re: Messages missing since 4.0 [message #465035 is a reply to message #464304] Wed, 28 March 2012 08:51 Go to previous messageGo to next message
Gen_Blacky is currently offline  Gen_Blacky
Messages: 3250
Registered: September 2006
Karma: 1
General (3 Stars)
br used ssgm logs for beacons not gamelog.


ssgm 4.0

void SSGM_Log_Beacon::Created(GameObject *obj)
{
	SSGMGameLog::Log_Gamelog("CREATED;OBJECT;%d;%s;%d;%d;%d;%d;%d;%d;%d;%d", Commands->Get_ID(obj), Commands->Get_Preset_Name(obj), int(pos.Y),int(pos.X),int(pos.Z),	int(Commands->Get_Facing(obj)),	int(Commands->Get_Max_Health(obj)),int(Commands->Get_Max_Shield_Strength(obj)),	Commands->Get_Player_Type(obj),Commands->Get_ID(Get_Beacon_Planter(obj)));
}

void SSGM_Log_Beacon::Destroyed(GameObject *obj)
{
	SSGMGameLog::Log_Gamelog("DESTROYED;OBJECT;%d;%s;%d;%d;%d", Commands->Get_ID(obj),Commands->Get_Preset_Name(obj), int(pos.Y), int(pos.X), int(pos.Z));
}


ssgm 2.0.2

FDSMessage(StrFormat("%ls disarmed a %s",Get_Wide_Player_Name(shooter),Translate_Preset(obj).c_str()),"_BEACON");


br

# Parse a line of input from the SSGMLog
sub parse_line
{
	my $input = shift;

	# _Vehicle is no longer used, but we will keep it for backwards
	# compatibility with ssaow 1.5 and lower
	if ( $input =~ /^\[\d\d:\d\d:\d\d\]\s_VEHICLE\s(.+)$/ )
	{
		vehicle($1);
	}
	elsif ( $input =~ /^\[\d\d:\d\d:\d\d\]\s_ALERT\s(.+)$/ )
	{
		alert($1);
	}
	elsif ( $input =~ /^\[\d\d:\d\d:\d\d\]\s_BEACON\s(.+)$/ )
	{
		beacon($1);
	}
	elsif ( $input =~ /^\[\d\d:\d\d:\d\d\]\s_GENERAL\s(.+)$/ )
	{
		general($1);
	}
	elsif ( $input =~ /^\[\d\d:\d\d:\d\d\]\s_OREDUMP\s(.+)$/ )
	{
		ssapb_oredump($1);
	}
	elsif ( $input =~ /^\[\d\d:\d\d:\d\d\]\s_BUILDING_PURCHASE\s(.+)$/ )		# MP Script for Spacer
	{
		buildingPurchase($1);
	}
	elsif ( $brconfig::gamelog_in_ssgm == 1
		&& $input =~ /^\[\d\d:\d\d:\d\d\]\s_GAMELOG\s(.+)$/
		&& modules::get_module ( "gamelog" ) )
	{
		$input =~ s/_GAMELOG\s//gi;			# Trim _Gamelog and one space
		gamelog::parse_line( $input );		# Send it to the gamelog for processing
	}

	undef $input;
}


gamelogs logs could be part of ssgm log.
either danpual needs to add beacon msgs to gamelog or add the old ssgm beacon logs in ssgm log.


http://s18.postimage.org/jc6qbn4k9/bricks3.png

[Updated on: Wed, 28 March 2012 08:59]

Report message to a moderator

Re: Messages missing since 4.0 [message #465038 is a reply to message #464304] Wed, 28 March 2012 12:15 Go to previous messageGo to next message
Gohax is currently offline  Gohax
Messages: 738
Registered: January 2009
Karma: 0
Colonel
Not a big deal, but whenever you buy a tank now, the "Unit Ready" sound doesn't play anymore.

http://i453.photobucket.com/albums/qq252/DOT_HaLo/hawke.png
Quote:

·OTBot·Gohax killed beerfull4 (Black Hand Sniper/Sniper Rifle Vs. Deadeye/Sniper Rifle).
·OTBot·beerfull4: see that for sure a auto aim
·OTBot·beerfull4: u know how i can tell
·OTBot·Gohax: LOL
·OTBot·Gohax: how can you tell?
·OTBot·beerfull4: becuz your american and americans are like that
·OTBot·Gohax: LOL!
·OTBot·beerfull4 has left the game.

Re: Messages missing since 4.0 [message #465044 is a reply to message #465038] Wed, 28 March 2012 16:52 Go to previous messageGo to next message
Ani is currently offline  Ani
Messages: 399
Registered: February 2012
Location: New York City
Karma: 0
Commander
Gohax wrote on Wed, 28 March 2012 12:15

Not a big deal, but whenever you buy a tank now, the "Unit Ready" sound doesn't play anymore.


I always found it to be kind of an annoyance. It played for everyone when someone bought a tank, and one would assume that after 2-3 seconds - the unit bought would be *ready* either way.
Re: Messages missing since 4.0 [message #465045 is a reply to message #465035] Wed, 28 March 2012 17:12 Go to previous messageGo to next message
YesNoMayb is currently offline  YesNoMayb
Messages: 176
Registered: February 2012
Karma: 0
Recruit
I want my "Unit Ready" back. Angry
Re: Messages missing since 4.0 [message #465048 is a reply to message #464304] Wed, 28 March 2012 17:50 Go to previous messageGo to next message
jonwil is currently offline  jonwil
Messages: 3556
Registered: February 2003
Karma: 0
General (3 Stars)

Missing "unit ready" sound fixed.


Jonathan Wilson aka Jonwil
Creator and Lead Coder of the Custom scripts.dll
Renegade Engine Guru
Creator and Lead Coder of TT.DLL
Official member of Tiberian Technologies
Re: Messages missing since 4.0 [message #465346 is a reply to message #464304] Mon, 02 April 2012 12:52 Go to previous messageGo to next message
T0RN is currently offline  T0RN
Messages: 293
Registered: January 2006
Location: Lunatic HQ
Karma: 0
Recruit
Oops, I edited and message went blank lol.

WIN, General, and Beacon seem to be missing. Still not sure if there's more
I don't have an old ssgm log file to compare it to

C4 also

[Updated on: Tue, 03 April 2012 04:15]

Report message to a moderator

Re: Messages missing since 4.0 [message #465413 is a reply to message #464304] Tue, 03 April 2012 12:28 Go to previous messageGo to next message
T0RN is currently offline  T0RN
Messages: 293
Registered: January 2006
Location: Lunatic HQ
Karma: 0
Recruit
No server status message like this anymore either :

[Server Status] Players: 15/50 - SFPS: 60 - BW: 1158 kbps

Re: Messages missing since 4.0 [message #465482 is a reply to message #464304] Wed, 04 April 2012 04:25 Go to previous messageGo to next message
danpaul88 is currently offline  danpaul88
Messages: 5795
Registered: June 2004
Location: England
Karma: 0
General (5 Stars)
Those server status messages are not part of stock brenbot or ssgm, perhaps they came from a plugin? Server status is only shown in response to the !gi command.

http://steamsignature.com/card/1/76561197975867233.png
Re: Messages missing since 4.0 [message #465490 is a reply to message #464304] Wed, 04 April 2012 06:45 Go to previous messageGo to next message
Ani is currently offline  Ani
Messages: 399
Registered: February 2012
Location: New York City
Karma: 0
Commander
I'm pretty sure you have no idea what you're saying.

I just ran 2 individual servers, both running the latest BR that is offered through beta4 TT...

One server ran TT, the other one 3.4 scripts - there are a lot of messages missing. For instance, when the game ends, it doesn't show how. Beacons never show up either. BIATCH is missing as well (not that I would know) (anti-cheat simply doesnt get relayed anymore).


Re: Messages missing since 4.0 [message #465491 is a reply to message #464304] Wed, 04 April 2012 07:08 Go to previous messageGo to next message
T0RN is currently offline  T0RN
Messages: 293
Registered: January 2006
Location: Lunatic HQ
Karma: 0
Recruit
I'm not sure about what I'm saying either lol.
I just know messages I had on my old server are now missing.

Looking through it seems renlog messages are missing,and gamelog messages seem ok.
BIATCH, Vehkill, C4, End, current and a few others



Huh

[Updated on: Wed, 04 April 2012 07:30]

Report message to a moderator

Re: Messages missing since 4.0 [message #465496 is a reply to message #465413] Wed, 04 April 2012 07:42 Go to previous messageGo to next message
danpaul88 is currently offline  danpaul88
Messages: 5795
Registered: June 2004
Location: England
Karma: 0
General (5 Stars)
I am specifically referring to this message;

T0RN wrote on Tue, 03 April 2012 20:28

No server status message like this anymore either :

[Server Status] Players: 15/50 - SFPS: 60 - BW: 1158 kbps





That one is not part of stock BRenBot or SSGM 2.x. I said nothing about the other messages mentioned in this topic.

Jonwil has previously stated (either here or elsewhere) that he needs someone to post copies of the raw SSGM log messages that are missing from SSGM 4.0 so he can re-implement them. Until they are implemented in SSGM 4.0 there's nothing for the bot to show because they simply don't exist.

As for BIATCH messages not being shown, this is because they are no longer prefixed with BIATCH so BRenBot's plugin can't parse them. I believe the intended fix is to re-add the BIATCH prefix to those messages.


http://steamsignature.com/card/1/76561197975867233.png
Re: Messages missing since 4.0 [message #465499 is a reply to message #465496] Wed, 04 April 2012 08:01 Go to previous messageGo to next message
T0RN is currently offline  T0RN
Messages: 293
Registered: January 2006
Location: Lunatic HQ
Karma: 0
Recruit
danpaul88 wrote on Wed, 04 April 2012 10:42

I am specifically referring to this message;

T0RN wrote on Tue, 03 April 2012 20:28

No server status message like this anymore either :

[Server Status] Players: 15/50 - SFPS: 60 - BW: 1158 kbps





That one is not part of stock BRenBot or SSGM 2.x. I said nothing about the other messages mentioned in this topic.

Jonwil has previously stated (either here or elsewhere) that he needs someone to post copies of the raw SSGM log messages that are missing from SSGM 4.0 so he can re-implement them. Until they are implemented in SSGM 4.0 there's nothing for the bot to show because they simply don't exist.

As for BIATCH messages not being shown, this is because they are no longer prefixed with BIATCH so BRenBot's plugin can't parse them. I believe the intended fix is to re-add the BIATCH prefix to those messages.

yeah sorry, that was a custom message, I should have asked first.
I wish I had old logs to compare to, but I don't. I just know some messages are missing, not the actual raw log messages Sad
Re: Messages missing since 4.0 [message #465501 is a reply to message #464304] Wed, 04 April 2012 08:22 Go to previous messageGo to next message
T0RN is currently offline  T0RN
Messages: 293
Registered: January 2006
Location: Lunatic HQ
Karma: 0
Recruit
_BEACON
_C4
_VEHKILL
_GENERAL

Not sure about this:

_CHANGECHARACTER ??
Re: Messages missing since 4.0 [message #465524 is a reply to message #464304] Wed, 04 April 2012 12:54 Go to previous messageGo to next message
reckneya is currently offline  reckneya
Messages: 128
Registered: November 2005
Location: Holland
Karma: 0
Recruit

Purchased?

Brandan wrote on Tue, 10 April 2012 07:13

Also what happened to you can change your ISP I doubt you even know what a VPN is or even a remote idea of how the Internet even works.
If I disregard the deficit of cohesion between his statements, and the lack of proper spelling and use of symbols I think I know what he was trying to say, and I lol'd. No hard feelings though Brandan Wink
Re: Messages missing since 4.0 [message #465553 is a reply to message #465501] Wed, 04 April 2012 21:44 Go to previous messageGo to next message
Xpert is currently offline  Xpert
Messages: 1588
Registered: December 2005
Location: New York City
Karma: 0
General (1 Star)
T0RN wrote on Wed, 04 April 2012 11:22

_BEACON
_C4
_VEHKILL
_GENERAL

Not sure about this:

_CHANGECHARACTER ??



_C4 and _BEACON doesn't exist because the ssgm log for it isn't coded in. Only raw gamelog. That's not hard to make. Just need to inform JonWil.


Oh and BIATCH logs don't relay because the format for it was changed. I remember them saying they will revert to the old way, that way all bots will just read BIATCH messages like normal before the change.


http://i32.photobucket.com/albums/d42/XpertMaverick/xpertyankee.jpg

Creator of NetGuard, an IRC network regulator.
Developer of the CloudyServ 0.982-X project.
Developer of the CloudyServ Ren-X bot.

Part time streamer - https://twitch.tv/gg_wonder

[Updated on: Wed, 04 April 2012 21:45]

Report message to a moderator

Re: Messages missing since 4.0 [message #465723 is a reply to message #465553] Sat, 07 April 2012 18:38 Go to previous messageGo to previous message
T0RN is currently offline  T0RN
Messages: 293
Registered: January 2006
Location: Lunatic HQ
Karma: 0
Recruit
Xpert wrote on Thu, 05 April 2012 00:44


_C4 and _BEACON doesn't exist because the ssgm log for it isn't coded in. Only raw gamelog. That's not hard to make. Just need to inform JonWil.


I am informing you JonWil Tell Me
Previous Topic: Fixing roadkill bug
Next Topic: time limit and BRenBot
Goto Forum:
  


Current Time: Sat Jul 13 19:42:57 MST 2024

Total time taken to generate the page: 0.01165 seconds